bug#55518: [PATCH] gnu: Add python-gatt.
Commit Message
Hi,
I added a commit log and applied with the changes below, as suggested by
Tobias (for the description).
The inputs are propagated because, for instance, the code reads:
--8<---------------cut here---------------start------------->8---
try:
import dbus
import dbus.mainloop.glib
except ImportError:
import sys
print("Module 'dbus' not found")
print("Please run: sudo apt-get install python3-dbus")
print("See also: https://github.com/getsenic/gatt-python#installing-gatt-sdk-for-python")
sys.exit(1)
--8<---------------cut here---------------end--------------->8---
Thus, if you install python-gatt in a profile, python-dbus should be
propagated as well so it “just works”.
Thanks,
Ludo’.
Comments
On Fri. (May 27, 2022) at 06:02:45 PM -04, Ludovic Courtès <ludo@gnu.org> wrote:
> Hi,
>
> I added a commit log and applied with the changes below, as suggested by
> Tobias (for the description).
…ah; heh, that was definitely not how I'd read his suggestion. I thought
~@acronym~ was used in every case, with the full acronym spelled out
only in first case, so thought I'd gotten it right in my last
patch. Sorry about that.
> The inputs are propagated because, for instance, the code reads:
>
> try:
> import dbus
> import dbus.mainloop.glib
> except ImportError:
> import sys
> print("Module 'dbus' not found")
> print("Please run: sudo apt-get install python3-dbus")
> print("See also: https://github.com/getsenic/gatt-python#installing-gatt-sdk-for-python")
> sys.exit(1)
>
> Thus, if you install python-gatt in a profile, python-dbus should be
> propagated as well so it “just works”.
Mmm; O. K. That makes sense. Thanks a ton for explaining, Ludo; it's
super appreciated.
@@ -31806,32 +31806,35 @@ (define-public python-srt
composing subtitles in the SRT file format.")
(license license:expat)))
-(define python-gatt
+(define-public python-gatt
(package
(name "python-gatt")
(version "0.2.7")
(source (origin
(method url-fetch)
(uri (pypi-uri "gatt" version))
- (sha256 (base32
- "0fjf066jixk30fr8xwfalwfnhqpr56yv0cccyypnx2qp9bi9svb2"))))
- (inputs (list python-dbus python-pygobject))
+ (sha256
+ (base32
+ "0fjf066jixk30fr8xwfalwfnhqpr56yv0cccyypnx2qp9bi9svb2"))))
+ (propagated-inputs (list python-dbus python-pygobject))
(build-system python-build-system)
(home-page "https://github.com/getsenic/gatt-python")
(synopsis "Bluetooth GATT SDK for Python")
(description "The Bluetooth @acronym{GATT, Generic ATTribute Profile}
-@acronym{SDK, Software Development Kit} for Python helps you implementing and
-communicating with any Bluetooth Low Energy device that has a @acronym{GATT}
+@acronym{SDK, Software Development Kit} for Python helps you implement and
+communicate with any Bluetooth Low Energy device that has a GATT
profile. It supports:
+
@itemize @bullet
@item Discovering nearby Bluetooth Low Energy devices
@item Connecting and disconnecting devices
-@item Implementing your custom @acronym{GATT} profile
-@item Accessing all @acronym{GATT} services
-@item Accessing all @acronym{GATT} characteristics
+@item Implementing your custom GATT profile
+@item Accessing all GATT services
+@item Accessing all GATT characteristics
@item Reading characteristic values
@item Writing characteristic values
@item Subscribing for characteristic value change notifications
@end itemize
+
Currently, Linux is the only platform supported by this library.")
(license license:expat)))