diff mbox series

[bug#55227,core-updates,4/8] commencement: tcc-boot0: Use NYACC-1.00.2.

Message ID 20220502182434.32130-4-janneke@gnu.org
State New
Headers show
Series The Full Source Bootstrap | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Janneke Nieuwenhuizen May 2, 2022, 6:24 p.m. UTC
* gnu/packages/commencement.scm (tcc-boot0): Call 'bootstrap-origin' on source
and on the source of NYACC-0.99.  Use https source URL.  Update NYACC to
1.00.2.
---
 gnu/packages/commencement.scm | 24 +++++++++++++-----------
 1 file changed, 13 insertions(+), 11 deletions(-)

Comments

Ludovic Courtès May 12, 2022, 10:47 a.m. UTC | #1
"Jan (janneke) Nieuwenhuizen" <janneke@gnu.org> skribis:

> * gnu/packages/commencement.scm (tcc-boot0): Call 'bootstrap-origin' on source
> and on the source of NYACC-0.99.  Use https source URL.  Update NYACC to
> 1.00.2.

[...]

> +    (source (bootstrap-origin
> +             (origin
> +               (method url-fetch)
> +               (uri (string-append
> +                     "https://lilypond.org/janneke/mes/20191117/"
> +                     "/tcc-" version ".tar.gz"))
> +               (sha256
> +                (base32
> +                 "1qbybw7mxbgkv3sazvz1v7c8byq998vk8f1h25ik8w3d2l63lxng")))))

Same here for ‘bootstrap-origin’ and the URL.

Otherwise LGTM.

>      (native-inputs
>       `(("mes" ,mes-boot)
> -       ("nyacc-source" ,(origin (inherit (package-source nyacc-0.99))
> -                                (snippet #f)))
> +       ("nyacc-source" ,(bootstrap-origin
> +                         (origin (inherit (package-source nyacc-1.00.2))
> +                                 (snippet #f))))
>         ("mescc-tools" ,%bootstrap-mescc-tools)
>         ,@(%boot-gash-inputs)))

In a subsequent patch (not a blocker), we can look at removing input
labels.

Ludo’.
Janneke Nieuwenhuizen May 13, 2022, 8:09 a.m. UTC | #2
Ludovic Courtès writes:

Hi,

> "Jan (janneke) Nieuwenhuizen" <janneke@gnu.org> skribis:
>
>> * gnu/packages/commencement.scm (tcc-boot0): Call 'bootstrap-origin' on source
>> and on the source of NYACC-0.99.  Use https source URL.  Update NYACC to
>> 1.00.2.
>
> [...]
>
>> +    (source (bootstrap-origin
>> +             (origin
>> +               (method url-fetch)
>> +               (uri (string-append
>> +                     "https://lilypond.org/janneke/mes/20191117/"
>
> Same here for ‘bootstrap-origin’ and the URL.
>
> Otherwise LGTM.

Done.

>>      (native-inputs
>>       `(("mes" ,mes-boot)
>> -       ("nyacc-source" ,(origin (inherit (package-source nyacc-0.99))
>> -                                (snippet #f)))
>> +       ("nyacc-source" ,(bootstrap-origin
>> +                         (origin (inherit (package-source nyacc-1.00.2))
>> +                                 (snippet #f))))
>>         ("mescc-tools" ,%bootstrap-mescc-tools)
>>         ,@(%boot-gash-inputs)))
>
> In a subsequent patch (not a blocker), we can look at removing input
> labels.

Okay, that would be nice.
Janneke
diff mbox series

Patch

diff --git a/gnu/packages/commencement.scm b/gnu/packages/commencement.scm
index 468a846e76..7f1ba7aa6a 100644
--- a/gnu/packages/commencement.scm
+++ b/gnu/packages/commencement.scm
@@ -5,7 +5,7 @@ 
 ;;; Copyright © 2014, 2015, 2017 Mark H Weaver <mhw@netris.org>
 ;;; Copyright © 2017, 2018, 2019, 2021, 2022 Efraim Flashner <efraim@flashner.co.il>
 ;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
-;;; Copyright © 2018, 2019, 2020, 2021 Jan (janneke) Nieuwenhuizen <janneke@gnu.org>
+;;; Copyright © 2018, 2019, 2020, 2021, 2022 Jan (janneke) Nieuwenhuizen <janneke@gnu.org>
 ;;; Copyright © 2019, 2020, 2021 Marius Bakke <marius@gnu.org>
 ;;; Copyright © 2020, 2022 Timothy Sample <samplet@ngyro.com>
 ;;; Copyright © 2020 Guy Fleury Iteriteka <gfleury@disroot.org>
@@ -618,22 +618,24 @@  (define tcc-boot0
     (inherit tcc)
     (name "tcc-boot0")
     (version "0.9.26-1103-g6e62e0e")
-    (source (origin
-              (method url-fetch)
-              (uri (string-append
-                    "http://lilypond.org/janneke/mes/20191117/"
-                    "/tcc-" version ".tar.gz"))
-              (sha256
-               (base32
-                "1qbybw7mxbgkv3sazvz1v7c8byq998vk8f1h25ik8w3d2l63lxng"))))
+    (source (bootstrap-origin
+             (origin
+               (method url-fetch)
+               (uri (string-append
+                     "https://lilypond.org/janneke/mes/20191117/"
+                     "/tcc-" version ".tar.gz"))
+               (sha256
+                (base32
+                 "1qbybw7mxbgkv3sazvz1v7c8byq998vk8f1h25ik8w3d2l63lxng")))))
     (build-system gnu-build-system)
     (supported-systems '("i686-linux" "x86_64-linux"))
     (inputs '())
     (propagated-inputs '())
     (native-inputs
      `(("mes" ,mes-boot)
-       ("nyacc-source" ,(origin (inherit (package-source nyacc-0.99))
-                                (snippet #f)))
+       ("nyacc-source" ,(bootstrap-origin
+                         (origin (inherit (package-source nyacc-1.00.2))
+                                 (snippet #f))))
        ("mescc-tools" ,%bootstrap-mescc-tools)
        ,@(%boot-gash-inputs)))
     (arguments