diff mbox series

[bug#55030,02/30] gnu: elm: Rename package to match the command.

Message ID 20220419233214.275789-2-philip@philipmcgrath.com
State Accepted
Headers show
Series gnu: elm: Update to 0.19.1. Add build system & importer. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Philip McGrath April 19, 2022, 11:31 p.m. UTC
* gnu/packages/elm.scm (elm-compiler): Rename to ...
(elm): ... this variable.
[description]: Tweak.
---
 gnu/packages/elm.scm | 16 ++++++++--------
 1 file changed, 8 insertions(+), 8 deletions(-)

Comments

Ludovic Courtès May 1, 2022, 8:22 p.m. UTC | #1
Philip McGrath <philip@philipmcgrath.com> skribis:

> * gnu/packages/elm.scm (elm-compiler): Rename to ...
> (elm): ... this variable.
> [description]: Tweak.

Could you add a deprecated alias, with ‘deprecated-package’?
Philip McGrath May 1, 2022, 9:27 p.m. UTC | #2
On 5/1/22 16:22, Ludovic Courtès wrote:
> Philip McGrath <philip@philipmcgrath.com> skribis:
> 
>> * gnu/packages/elm.scm (elm-compiler): Rename to ...
>> (elm): ... this variable.
>> [description]: Tweak.
> 
> Could you add a deprecated alias, with ‘deprecated-package’?

Yes, will do. (Though it will be at least a few days before I circle 
back to this.)
diff mbox series

Patch

diff --git a/gnu/packages/elm.scm b/gnu/packages/elm.scm
index 708c1cf0d2..be2e4ebcbd 100644
--- a/gnu/packages/elm.scm
+++ b/gnu/packages/elm.scm
@@ -33,13 +33,13 @@  (define-module (gnu packages elm)
 ;; The `elm` build usually calls out to itself via Template Haskell to compile
 ;; the `elm reactor` web app (which depends on additional Elm packages) and
 ;; embeds the static files into itself.  The reactor isn't required to compile
-;; elm applications, so we want to skip it from the bootstrap package, but we
+;; Elm applications, so we want to skip it from the bootstrap package, but we
 ;; also want to be able to enable it once we can build it.  We patch Elm to
-;; instead look for the files on disk relative to the executable and exit with
-;; a useful error message if they aren't there.
-(define-public elm-compiler
+;; instead look for the files on disk relative to the executable and to have
+;; `elm reactor` exit with a useful error message if they aren't there.
+(define-public elm
   (package
-    (name "elm-compiler")
+    (name "elm")
     (version "0.19.1")
     (source
      (origin
@@ -91,7 +91,7 @@  (define-public elm-compiler
     (home-page "https://elm-lang.org")
     (synopsis "Programming language for Web applications")
     (description
-     "This package provides Elm, a statically-typed functional programming
-language for the browser.  It includes commands for developers such as
-@command{elm make} and @command{elm repl}.")
+     "Elm is a statically-typed, purely-functional programming language for
+the browser.  The @command{elm} exectable includes commands for developers
+such as @command{elm make} and @command{elm repl}.")
     (license license:bsd-3)))