diff mbox series

[bug#54912] gnu: Add r-acme.

Message ID 20220413141258.30929-1-madalinionel.patrascu@mdc-berlin.de
State Accepted
Headers show
Series [bug#54912] gnu: Add r-acme. | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Mădălin Ionel Patrașcu April 13, 2022, 2:12 p.m. UTC
* gnu/packages/bioconductor.scm (r-acme): New variable.
---
 gnu/packages/bioconductor.scm | 30 ++++++++++++++++++++++++++++++
 1 file changed, 30 insertions(+)

Comments

Ricardo Wurmus April 14, 2022, 10:43 a.m. UTC | #1
Applied, thanks!

I removed the comment at the top, because the bioc home page is fine to
use.  The importer just extracts the home page as it is declared in the
package’s DESCRIPTION file.  It’s not unusual that the home page there
has been abandoned as developers often forget about updating the
DESCRIPTION file.
diff mbox series

Patch

diff --git a/gnu/packages/bioconductor.scm b/gnu/packages/bioconductor.scm
index 803437a033..69e9e14dd3 100644
--- a/gnu/packages/bioconductor.scm
+++ b/gnu/packages/bioconductor.scm
@@ -11642,6 +11642,36 @@  (define-public r-universalmotif
 motifs, and others.")
     (license license:gpl3)))
 
+;;  The homepage (http://watson.nci.nih.gov/~sdavis) seems to be inaccessible
+;; anymore so I changed it to the Bioconductor page of the package.
+(define-public r-acme
+  (package
+    (name "r-acme")
+    (version "2.50.0")
+    (source (origin
+              (method url-fetch)
+              (uri (bioconductor-uri "ACME" version))
+              (sha256
+               (base32
+                "0h4bqbbqcwc938q7lysk5l35f64xz9d1bsniv2wshmlr4rr0zpcg"))))
+    (properties `((upstream-name . "ACME")))
+    (build-system r-build-system)
+    (propagated-inputs (list r-biobase r-biocgenerics))
+    (home-page "https://bioconductor.org/packages/aCGH/")
+    (synopsis "Calculating microarray enrichment")
+    (description
+     "This package implements
+@dfn{algorithms for calculating microarray enrichment} (ACME), and it is a set
+of tools for analysing tiling array of
+@dfn{combined chromatin immunoprecipitation with DNA microarray} (ChIP/chip),
+DNAse hypersensitivity, or other experiments that result in regions of the
+genome showing enrichment.  It does not rely on a specific array technology
+(although the array should be a tiling array), is very general (can be applied
+in experiments resulting in regions of enrichment), and is very insensitive to
+array noise or normalization methods.  It is also very fast and can be applied
+on whole-genome tiling array experiments quite easily with enough memory.")
+    (license license:gpl2+)))
+
 ;; This is a CRAN package, but it depends on Bioconductor packages, so we put
 ;; it here.
 (define-public r-activedriverwgs