@@ -73,6 +73,7 @@ (define-module (gnu packages finance)
#:use-module (gnu packages documentation)
#:use-module (gnu packages dns)
#:use-module (gnu packages emacs)
+ #:use-module (gnu packages emacs-xyz)
#:use-module (gnu packages dbm)
#:use-module (gnu packages gettext)
#:use-module (gnu packages gnome)
@@ -455,6 +456,37 @@ (define-public emacs-ledger-mode
This package provides the Emacs mode.")
(license license:gpl2+)))
+(define-public emacs-hledger-mode
+ (let ((commit "9ac07ff0adbce6a402c17e789b1750f9da0d22f4")
+ (revision "1"))
+ (package
+ (name "emacs-hledger-mode")
+ (version (git-version "20210706.1225" revision commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/narendraj9/hledger-mode")
+ (commit commit)))
+ (sha256
+ (base32
+ "0x3dgws8nh7q8x7zzjwbm5k9n7gi7qqd3ww7y51fbx6p6ii3jpp4"))))
+ (build-system emacs-build-system)
+ (propagated-inputs `(("emacs-popup" ,emacs-popup)
+ ("emacs-async" ,emacs-async)
+ ("emacs-htmlize" ,emacs-htmlize)))
+ (arguments
+ '(#:include '("^[^/]+.el$")
+ #:exclude '()))
+ (home-page "https://github.com/narendraj9/hledger-mode")
+ (synopsis "Mode for writing journal entries for hledger")
+ (description
+ "A major mode for writing hledger journal files. It generates some
+useful reports along with some financial ratios that can help you
+keep a check on your financial health. This is an attempt to
+organize personal finances for Emacs users. If you don not like this,
+try @code{emacs-ledger-mode}.")
+ (license license:gpl3))))
+
(define-public geierlein
(package
(name "geierlein")