diff mbox series

[bug#54342] gnu: Add r-zoeppritz.

Message ID 20220311181935.14243-1-madalinionel.patrascu@mdc-berlin.de
State Accepted
Headers show
Series [bug#54342] gnu: Add r-zoeppritz. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Mădălin Ionel Patrașcu March 11, 2022, 6:19 p.m. UTC
* gnu/packages/cran.scm (r-zoeppritz): New variable.
---
 gnu/packages/cran.scm | 20 ++++++++++++++++++++
 1 file changed, 20 insertions(+)

Comments

Ricardo Wurmus April 4, 2022, 8:45 a.m. UTC | #1
Thanks for the patch!  I just applied it.
diff mbox series

Patch

diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 4178971251..698b078fc1 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -32715,3 +32715,23 @@  (define-public r-ggh4x
 facets.  It also allows multiple colour, fill scales per plot and hosts a
 smaller collection of stats, geoms and axis guides.")
     (license license:expat)))
+
+(define-public r-zoeppritz
+  (package
+    (name "r-zoeppritz")
+    (version "1.0-8")
+    (source (origin
+              (method url-fetch)
+              (uri (cran-uri "zoeppritz" version))
+              (sha256
+               (base32
+                "1711szx9zz17q6pfinyzlyrw7m9772c8ywlixqar2l165bkjalgm"))))
+    (properties `((upstream-name . "zoeppritz")))
+    (build-system r-build-system)
+    (home-page "https://cran.r-project.org/package=zoeppritz")
+    (synopsis "Seismic reflection and scattering coefficients for waves")
+    (description
+     "The @code{r-zoeppritz} package calculates and plots scattering matrix
+coefficients or scattering amplitudes, for seismological P and S-waves at an
+interface.")
+    (license license:gpl2+)))