@@ -9999,6 +9999,34 @@ (define-public go-github-com-julienschmidt-httprouter
(home-page "https://github.com/julienschmidt/httprouter")
(license license:bsd-3)))
+(define-public go-github-com-mailru-easyjson
+ (package
+ (name "go-github-com-mailru-easyjson")
+ (version "0.7.7")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/mailru/easyjson")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0clifkvvy8f45rv3cdyv58dglzagyvfcqb63wl6rij30c5j2pzc1"))))
+ (build-system go-build-system)
+ (arguments
+ '(#:import-path "github.com/mailru/easyjson"))
+ (propagated-inputs (list go-github-com-josharian-intern))
+ (synopsis "Fast JSON serializer for golang")
+ (description
+ "Package @code{easyjson} provides a fast and easy way to
+marshal/unmarshal Go structs to/from JSON without the use of reflection.
+
+In performance tests, @code{easyjson} outperforms the standard
+@code{encoding/json} package by a factor of 4-5x, and other JSON
+encoding packages by a factor of 2-3x.")
+ (home-page "https://github.com/mailru/easyjson")
+ (license license:expat)))
+
(define-public go-google-golang-org-protobuf
(package
(name "go-google-golang-org-protobuf")