@@ -9967,6 +9967,38 @@ (define-public go-github-com-josharian-intern
(home-page "https://github.com/josharian/intern")
(license license:expat)))
+(define-public go-github-com-julienschmidt-httprouter
+ (package
+ (name "go-github-com-julienschmidt-httprouter")
+ (version "1.3.0")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/julienschmidt/httprouter")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1a6sy0ysqknsjssjh7qg1dqn21xmj9a36c57nrk7srfmab4ffmk1"))))
+ (build-system go-build-system)
+ (arguments
+ '(#:import-path "github.com/julienschmidt/httprouter"))
+ (synopsis "High performance HTTP request router")
+ (description
+ "HttpRouter is a lightweight high performance HTTP request router
+(also called multiplexer or just mux for short) for Go.
+
+In contrast to the default mux of Go's @code{net/http} package, this
+router supports variables in the routing pattern and matches against the
+request method. It also scales better.
+
+The router is optimized for high performance and a small memory
+footprint. It scales well even with very long paths and a large number
+of routes. A compressing dynamic trie (radix tree) structure is used for
+efficient matching.")
+ (home-page "https://github.com/julienschmidt/httprouter")
+ (license license:bsd-3)))
+
(define-public go-google-golang-org-protobuf
(package
(name "go-google-golang-org-protobuf")