@@ -9942,6 +9942,31 @@ (define-public go-github-com-go-stack-stack
(home-page "https://github.com/go-stack/stack")
(license license:expat)))
+(define-public go-github-com-josharian-intern
+ (package
+ (name "go-github-com-josharian-intern")
+ (version "1.0.0")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/josharian/intern")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1za48ppvwd5vg8vv25ldmwz1biwpb3p6qhf8vazhsfdg9m07951c"))))
+ (build-system go-build-system)
+ (arguments
+ '(#:import-path "github.com/josharian/intern"))
+ (synopsis "Intern Go strings")
+ (description
+ "Package intern interns strings. Interning is best effort only.
+Interned strings may be removed automatically at any time without
+notification. All functions may be called concurrently with themselves
+and each other.")
+ (home-page "https://github.com/josharian/intern")
+ (license license:expat)))
+
(define-public go-google-golang-org-protobuf
(package
(name "go-google-golang-org-protobuf")