diff mbox series

[bug#54511] gnu: Add r-cytobackbone.

Message ID 20220321191918.18123-1-madalinionel.patrascu@mdc-berlin.de
State Accepted
Headers show
Series [bug#54511] gnu: Add r-cytobackbone. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Mădălin Ionel Patrașcu March 21, 2022, 7:19 p.m. UTC
* gnu/packages/bioconductor.scm (r-cytobackbone): New variable.
---
 gnu/packages/bioconductor.scm | 38 +++++++++++++++++++++++++++++++++++
 1 file changed, 38 insertions(+)

Comments

M March 21, 2022, 8:17 p.m. UTC | #1
Mădălin Ionel Patrașcu schreef op ma 21-03-2022 om 20:19 [+0100]:
> +      (properties `((upstream-name #{.}# "CytoBackBone")))

This needs to be (upstream-name . "CytoBackBone") -- #{.}# is the
symbol containing a dot, so (upstream-name #{.}# "CytoBackBone") is a
three-element list and not a pair.

Greetings,
Maxime.
M March 21, 2022, 8:17 p.m. UTC | #2
Mădălin Ionel Patrașcu schreef op ma 21-03-2022 om 20:19 [+0100]:
> +      (license license:gpl2))))

Could you ask upstream if they meant gpl2 or gpl2-or-later?
M March 21, 2022, 8:19 p.m. UTC | #3
Mădălin Ionel Patrașcu schreef op ma 21-03-2022 om 20:19 [+0100]:
> +      (description
> +       "Single-cell technologies are the most suitable [...]

This doesn't seem a good description to me as it is one big word salad.
Also see ‘(guix)Synopses and Descriptions’ for some tips.

Greetings,
Maxime.
Mădălin Ionel Patrașcu March 22, 2022, 9:39 a.m. UTC | #4
Dear Maxime,



This is an artifact after I run guix style.

I missed it this time.


Thanks for spotting this!

All the best!

Mădălin Ionel Patrașcu

System Administrator
The Berlin Institute for Medical Systems Biology (BIMSB)
Max Delbrück Center (MDC)
Robert-Rössle-Straße 10
House 87, room 1.10
13125 Berlin, Germany


________________________________
From: Maxime Devos <maximedevos@telenet.be>
Sent: Monday, March 21, 2022 21:17
To: Patrascu, Madalin Ionel; 54511@debbugs.gnu.org
Subject: [ext] Re: [bug#54511] [PATCH] gnu: Add r-cytobackbone.

Mădălin Ionel Patrașcu schreef op ma 21-03-2022 om 20:19 [+0100]:
> +      (properties `((upstream-name #{.}# "CytoBackBone")))

This needs to be (upstream-name . "CytoBackBone") -- #{.}# is the
symbol containing a dot, so (upstream-name #{.}# "CytoBackBone") is a
three-element list and not a pair.

Greetings,
Maxime.
Mădălin Ionel Patrașcu March 22, 2022, 9:41 a.m. UTC | #5
Dear Maxime,


Thanks for the suggestion!

Now, I have asked this.

https://github.com/tchitchek-lab/CytoBackBone/issues/2

[https://opengraph.githubassets.com/0db2fcd2573d74d186964b02586c50768de2bd17394f06020ea67ddcba92e496/tchitchek-lab/CytoBackBone/issues/2]<https://github.com/tchitchek-lab/CytoBackBone/issues/2>

License · Issue #2 · tchitchek-lab/CytoBackBone · GitHub<https://github.com/tchitchek-lab/CytoBackBone/issues/2>
github.com
Dear Authors, Quick question: This project is licensed under GPL-2.0-only or the license GPL-2.0-or-later can be applied? I ask this because we try to add this to Guix. https://debbugs.gnu.org/cgi/bugreport.cgi?bug=54511 Thanks and all t...



All the best!

Mădălin Ionel Patrașcu

System Administrator
The Berlin Institute for Medical Systems Biology (BIMSB)
Max Delbrück Center (MDC)
Robert-Rössle-Straße 10
House 87, room 1.10
13125 Berlin, Germany


________________________________
From: Maxime Devos <maximedevos@telenet.be>
Sent: Monday, March 21, 2022 21:17
To: Patrascu, Madalin Ionel; 54511@debbugs.gnu.org
Subject: [ext] Re: [bug#54511] [PATCH] gnu: Add r-cytobackbone.

Mădălin Ionel Patrașcu schreef op ma 21-03-2022 om 20:19 [+0100]:
> +      (license license:gpl2))))

Could you ask upstream if they meant gpl2 or gpl2-or-later?
Mădălin Ionel Patrașcu March 22, 2022, 9:53 a.m. UTC | #6
Dear Maxime,



Bioinformatics is not my area of expertise ,and beside this, it was the end of a busy day and I wanted to finish this faster.
Sorry that I didn't treat this with more attention!


I will try to send again a path with a more readable description.


All the best!

Mădălin Ionel Patrașcu

System Administrator
The Berlin Institute for Medical Systems Biology (BIMSB)
Max Delbrück Center (MDC)
Robert-Rössle-Straße 10
House 87, room 1.10
13125 Berlin, Germany


________________________________
From: Maxime Devos <maximedevos@telenet.be>
Sent: Monday, March 21, 2022 21:19
To: Patrascu, Madalin Ionel; 54511@debbugs.gnu.org
Subject: [ext] Re: [bug#54511] [PATCH] gnu: Add r-cytobackbone.

Mădălin Ionel Patrașcu schreef op ma 21-03-2022 om 20:19 [+0100]:
> +      (description
> +       "Single-cell technologies are the most suitable [...]

This doesn't seem a good description to me as it is one big word salad.
Also see ‘(guix)Synopses and Descriptions’ for some tips.

Greetings,
Maxime.
Ricardo Wurmus March 29, 2022, 1:02 p.m. UTC | #7
I moved this to bioinformatics.scm.

Thanks!
diff mbox series

Patch

diff --git a/gnu/packages/bioconductor.scm b/gnu/packages/bioconductor.scm
index 55d397e5cf..6f5a040f65 100644
--- a/gnu/packages/bioconductor.scm
+++ b/gnu/packages/bioconductor.scm
@@ -10066,6 +10066,44 @@  (define-public r-consensusclusterplus
 cluster count and membership by stability evidence in unsupervised analysis.")
     (license license:gpl2)))
 
+;; It doesn't have a system of releases. This package depends on a bioconductor
+;; input.
+(define-public r-cytobackbone
+  (let ((commit "4c1a0a35cc5ae1f8f516127cec92351d96fe26e7") (revision "1"))
+    (package
+      (name "r-cytobackbone")
+      (version (git-version "1.0.0" revision commit))
+      (source (origin
+                (method git-fetch)
+                (uri (git-reference
+                      (url "https://github.com/tchitchek-lab/CytoBackBone")
+                      (commit commit)))
+                (file-name (git-file-name name version))
+                (sha256
+                 (base32
+                  "0ahiad14zcgdk42xzw5xryic2ibn2l8lkrcdvl2b5sz2js028yb3"))))
+      (properties `((upstream-name #{.}# "CytoBackBone")))
+      (build-system r-build-system)
+      (propagated-inputs (list r-flowcore r-flowutils r-fnn r-ggplot2
+                               r-preprocesscore))
+      (native-inputs (list r-knitr))
+      (home-page "https://github.com/tchitchek-lab/CytoBackBone")
+      (synopsis
+       "Merging of phenotype information from different cytometric profiles")
+      (description
+       "Single-cell technologies are the most suitable techniques for the
+characterization of cells by the differential expression of the molecules that
+define their roles and functions in tissues.  Among these techniques, mass
+cytometry represents a leap forward by increasing the number of available
+measurements to approximately 40 cell markers.  Thanks to this technology,
+detailed immune responses were described in several diseases.  However, the
+study of immune responses, such as that due to viral infections or auto-immune
+diseases, could be further improved by increasing the number of simultaneously
+measurable markers.  To increase this number, we designed an algorithm, named
+@code{CytoBackBone}, which combines phenotypic information of different
+cytometric profiles obtained from different cytometry panels.")
+      (license license:gpl2))))
+
 (define-public r-cytolib
   (package
     (name "r-cytolib")