Message ID | 874k3ydq40.fsf@reilysiegel.com |
---|---|
State | New |
Headers | show |
Series | None | expand |
Reily Siegel schreef op wo 16-03-2022 om 13:43 [+0100]: > + ;; Broken test dependencies. Upstream reports that the current version > + ;; of ring-defaults causes tests to hang, but that updating it would > + ;; break other test dependencies. > + #:tests? #f)) A link to the upstream bug report would be nice. Greetings, Maxime.
Reily Siegel schreef op wo 16-03-2022 om 13:43 [+0100]: > + (synopsis "High-performance event-driven HTTP client/server for Clojure") > + (description "High-performance event-driven HTTP client/server for > +Clojure.") The description seems to be missing here; it's just the synopsis duplicated here. Greetings, Maxime.
Reily Siegel schreef op wo 16-03-2022 om 13:43 [+0100]:
> + (license license:asl2.0)))
There's some bsd3 in test/org/httpkit/ring_request_proxy.clj.
Reily Siegel schreef op wo 16-03-2022 om 13:43 [+0100]:
> + #:tests? #f))
There's a file test/ssl_keystore. Certificates eventually expire. As
such, I would add a comment
;; Before re-enabling tests, make sure that test/ssl_keystore won't
;; expire, to ensure reproducibility.
Greetings,
Maxime.
Reily Siegel schreef op wo 16-03-2022 om 13:43 [+0100]: > +(define-public clojure-http-kit > + (package > + (name "clojure-http-kit") > + (version "2.5.3") > + (home-page "https://github.com/http-kit/http-kit") > + (source (origin > + (method git-fetch) > + (uri (git-reference > + (url home-page) As mentioned for a different package, home-page and the git-reference URL are considered independent even if sometimes they coincide. > + (commit (string-append "v" version)))) > + (file-name (git-file-name name version)) > + (sha256 > + (base32 > + "19m3j5ad4q7ywl0nd39vs0wha4md8fb846ykz0anv31rvdzv5yv3")))) Aside from the ssl_keystore thing, I see nothing ‘suspicious’ and the hash checks out. Greetings, Maxime.
diff --git a/gnu/packages/clojure.scm b/gnu/packages/clojure.scm index 850e1beea8..5e93a14dbc 100644 --- a/gnu/packages/clojure.scm +++ b/gnu/packages/clojure.scm @@ -514,6 +514,33 @@ (define-public clojure-data-xml lazy - should allow parsing and emitting of large XML documents") (license license:epl1.0))) +(define-public clojure-http-kit + (package + (name "clojure-http-kit") + (version "2.5.3") + (home-page "https://github.com/http-kit/http-kit") + (source (origin + (method git-fetch) + (uri (git-reference + (url home-page) + (commit (string-append "v" version)))) + (file-name (git-file-name name version)) + (sha256 + (base32 + "19m3j5ad4q7ywl0nd39vs0wha4md8fb846ykz0anv31rvdzv5yv3")))) + (build-system clojure-build-system) + (arguments + '(#:doc-dirs '() + #:java-source-dirs '("src/java") + ;; Broken test dependencies. Upstream reports that the current version + ;; of ring-defaults causes tests to hang, but that updating it would + ;; break other test dependencies. + #:tests? #f)) + (synopsis "High-performance event-driven HTTP client/server for Clojure") + (description "High-performance event-driven HTTP client/server for +Clojure.") + (license license:asl2.0))) + (define-public clojure-instaparse (let ((commit "dcfffad5b065e750f0f5835f017cdd8188b8ca2e") (version "1.4.9")) ; upstream forget to tag this release