Message ID | 20220131225040.268586-1-contact@phfrohring.com |
---|---|
State | Accepted |
Headers | show |
Series | [bug#53673] Add package: emacs-beacon-1.3.4 | expand |
Context | Check | Description |
---|---|---|
cbaines/comparison | success | View comparision |
cbaines/git branch | success | View Git branch |
cbaines/applying patch | success | View Laminar job |
cbaines/issue | success | View issue |
Hello, Pierre-Henry Fröhring <contact@phfrohring.com> writes: > --- > +(define-public emacs-beacon-1.3.4 Thank you. Some comments follow. First, the variable should not include the version string. So, you should write: (define-public emacs-beacon Then, you need to provide a proper commit message. Such messages are somewhat standardized in Guix. Here, this could be: gnu: Add emacs-beacon. * gnu/packages/emacs-xyz.scm (emacs-beacon): New variable. > + (package > + (name "emacs-beacon") > + (version "1.3.4") > + (source (origin > + (method url-fetch) > + (uri (string-append "https://github.com/Malabarba/" > + (second (string-split name #\-)) > + "/archive/refs/tags/" version ".tar.gz")) This URL is not stable. Use git-fetch method, with version string as the tag. > + (synopsis "A light that follows your cursor around so you don't lose it!") A synopsis may not start with an article. I suggest to use "guix lint" on your package definition. I suggest: Emacs minor mode creating a light that follows your cursor around > + (description > + "This is a global minor-mode. Turn it on everywhere with: (beacon-mode 1). > +Whenever the window scrolls a light will shine on top of your cursor so you know where it is. > +That’s it.") The part about "(beacon-mode 1)" belongs to the manual, not the description. The last sentence can be dropped, too. Also, sentences should be separated with two spaces in descriptions. I suggest: Beacon is an Emacs minor-mode. Whenever the ... where it is. Could you send an updated patch? Regards,
Thank you for the reply, here is the updated patch.
On Sun, 2022-02-06 at 21:39 +0100, Nicolas Goaziou wrote:
> updated patch?
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm index 8ce245c54a..ca35cb24b7 100644 --- a/gnu/packages/emacs-xyz.scm +++ b/gnu/packages/emacs-xyz.scm @@ -30032,3 +30032,24 @@ (define-public emacs-fennel-mode "Fennel mode provides font-lock, indentation, navigation, and REPL for Fennel code within Emacs.") (license license:gpl3+))) + +(define-public emacs-beacon-1.3.4 + (package + (name "emacs-beacon") + (version "1.3.4") + (source (origin + (method url-fetch) + (uri (string-append "https://github.com/Malabarba/" + (second (string-split name #\-)) + "/archive/refs/tags/" version ".tar.gz")) + (sha256 + (base32 + "0pvai7hk80an1q7lgjmlbzsdv2rwmhwsv0p0w7w52b7aqg59yd93")))) + (build-system emacs-build-system) + (home-page "https://github.com/Malabarba/beacon") + (synopsis "A light that follows your cursor around so you don't lose it!") + (description + "This is a global minor-mode. Turn it on everywhere with: (beacon-mode 1). +Whenever the window scrolls a light will shine on top of your cursor so you know where it is. +That’s it.") + (license license:gpl3+)))