diff mbox series

[bug#53208,04/39] gnu: Add rust-windows-x86-64-msvc-0.28.

Message ID tencent_722DC8A675AA52D6F5DF868E56395C894006@qq.com
State Accepted
Headers show
Series [bug#53208,01/39] gnu: Add rust-typed-arena-2. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Z572 Jan. 12, 2022, 3:27 p.m. UTC
* gnu/packages/crates-io.scm (rust-windows-x86-64-msvc-0.28): New variable.
---
 gnu/packages/crates-io.scm | 18 ++++++++++++++++++
 1 file changed, 18 insertions(+)

Comments

M Jan. 21, 2022, 7:30 p.m. UTC | #1
Z572 via Guix-patches via schreef op wo 12-01-2022 om 23:27 [+0800]:
> * gnu/packages/crates-io.scm (rust-windows-x86-64-msvc-0.28): New variable.

I don't see the point of packaging crates for Windows support in
Guix, since Guix (currently) does not support Windows at all,
except for some rather limited cross-compilation support.

Do things build without this crate?

Greetings,
Maxime.
Z572 Jan. 22, 2022, 3:37 a.m. UTC | #2
Maxime Devos <maximedevos@telenet.be> writes:

> [[PGP Signed Part:Undecided]]
> Z572 via Guix-patches via schreef op wo 12-01-2022 om 23:27 [+0800]:
>> * gnu/packages/crates-io.scm (rust-windows-x86-64-msvc-0.28): New variable.
>
> I don't see the point of packaging crates for Windows support in
> Guix, since Guix (currently) does not support Windows at all,
> except for some rather limited cross-compilation support.
>
see https://github.com/rust-lang/cargo/issues/4544

https://github.com/rust-lang/cargo/issues/4544#issuecomment-332846630
  Cargo will asset that all dependencies exist (optional,
  platform-specific, or not) to generate a lock file.

> Do things build without this crate?
Cargo need all dependency, even though it’s optional or platform-specific.
so if missing any one optional dependency, build will fail, maybe edit
crate's Cargo.toml files to remove them can be work, but it is a
terrible hack.
>
> Greetings,
> Maxime.
>
> [[End of PGP Signed Part]]
Tobias Geerinckx-Rice Jan. 23, 2022, 1:39 a.m. UTC | #3
Hullo Z,

Z572 via Guix-patches via 写道:
> Cargo need all dependency, even though it’s optional or 
> platform-specific.
> so if missing any one optional dependency, build will fail, 
> maybe edit
> crate's Cargo.toml files to remove them can be work, but it is a
> terrible hack.

I think it's a hack worth trying if upstream can't or won't fix 
it.

Kind regards,

T G-R
M Jan. 23, 2022, 9:02 p.m. UTC | #4
Tobias Geerinckx-Rice schreef op zo 23-01-2022 om 02:39 [+0100]:
> Z572 via Guix-patches via 写道:
> > Cargo need all dependency, even though it’s optional or 
> > platform-specific.
> > so if missing any one optional dependency, build will fail, 
> > maybe edit
> > crate's Cargo.toml files to remove them can be work, but it is a
> > terrible hack.

I haven't received this mail by Z572, any idea what happened here?

Greetings,
Maxime.
Z572 Jan. 24, 2022, 9:55 a.m. UTC | #5
Tobias Geerinckx-Rice <me@tobias.gr> writes:

> [[PGP Signed Part:Undecided]]
> Hullo Z,
>
> Z572 via Guix-patches via 写道:
>> Cargo need all dependency, even though it’s optional or
>> platform-specific.
>> so if missing any one optional dependency, build will fail, maybe
>> edit
>> crate's Cargo.toml files to remove them can be work, but it is a
>> terrible hack.
>
> I think it's a hack worth trying if upstream can't or won't fix it.

Ok, I will try edit Cargo.toml in the future.

>
> Kind regards,
>
> T G-R
>
> [[End of PGP Signed Part]]
Z572 Jan. 24, 2022, 10:01 a.m. UTC | #6
Maxime Devos <maximedevos@telenet.be> writes:

> [[PGP Signed Part:Undecided]]
> Tobias Geerinckx-Rice schreef op zo 23-01-2022 om 02:39 [+0100]:
>> Z572 via Guix-patches via 写道:
>> > Cargo need all dependency, even though it’s optional or 
>> > platform-specific.
>> > so if missing any one optional dependency, build will fail, 
>> > maybe edit
>> > crate's Cargo.toml files to remove them can be work, but it is a
>> > terrible hack.
>
> I haven't received this mail by Z572, any idea what happened here?
send mail to you fail, postmaster@qq.com say:
  host mx1.telenet-ops.be [195.130.132.8] said: 452 4.1.1
  <maximedevos@telenet.be> Greylisting in action, please try again later
  (in reply to RCPT TO command) 

maybe telenet.be think i'm spam :)

>
> Greetings,
> Maxime.
>
> [[End of PGP Signed Part]]
diff mbox series

Patch

diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index a64adda4fc..ebcf4e26a8 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -65531,6 +65531,24 @@  (define-public rust-windows-0.9
     (description "Rust for Windows")
     (license (list license:expat license:asl2.0))))
 
+(define-public rust-windows-x86-64-msvc-0.28
+  (package
+    (name "rust-windows-x86-64-msvc")
+    (version "0.28.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (crate-uri "windows_x86_64_msvc" version))
+       (file-name (string-append name "-" version ".tar.gz"))
+       (sha256
+        (base32 "17z8q25pd3dp6b84qm9nlayd3ym78sbryxlqmgcxvz9vpmy8qarz"))))
+    (build-system cargo-build-system)
+    (arguments `(#:skip-build? #t))
+    (home-page "https://github.com/microsoft/windows-rs")
+    (synopsis "Code gen support for the windows crate")
+    (description "Code gen support for the windows crate")
+    (license (list license:expat license:asl2.0))))
+
 (define-public rust-windows-gen-0.9
   (package
     (name "rust-windows-gen")