diff mbox series

[bug#53213] daemon: Always default to gzip for log compression.

Message ID 20220112172118.12250-1-ludo@gnu.org
State Accepted
Headers show
Series [bug#53213] daemon: Always default to gzip for log compression. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Ludovic Courtès Jan. 12, 2022, 5:21 p.m. UTC
* nix/libstore/globals.cc (Settings::Settings): Have 'logCompression'
default to COMPRESSION_GZIP unconditionally.
* gnu/services/base.scm (<guix-configuration>)[log-compression]: Default
to 'gzip.
* doc/guix.texi (Invoking guix-daemon, Base Services): Adjust accordingly.
---
 doc/guix.texi           | 4 ++--
 gnu/services/base.scm   | 2 +-
 nix/libstore/globals.cc | 4 ----
 3 files changed, 3 insertions(+), 7 deletions(-)

Hello!

I think bzip2 compression of the build logs doesn’t buy us much, it
doesn’t play well with ‘guix publish’, and bzip2 is generally rather
uncommon these days—hence this patch.

Thoughts?

Ludo’.


base-commit: cd68fc1e42f3f233ba5ccfd1323e46509a970d6b

Comments

Maxim Cournoyer Jan. 14, 2022, 2:37 a.m. UTC | #1
Hi Ludo,

Ludovic Courtès <ludo@gnu.org> writes:

> * nix/libstore/globals.cc (Settings::Settings): Have 'logCompression'
> default to COMPRESSION_GZIP unconditionally.
> * gnu/services/base.scm (<guix-configuration>)[log-compression]: Default
> to 'gzip.
> * doc/guix.texi (Invoking guix-daemon, Base Services): Adjust accordingly.
> ---
>  doc/guix.texi           | 4 ++--
>  gnu/services/base.scm   | 2 +-
>  nix/libstore/globals.cc | 4 ----
>  3 files changed, 3 insertions(+), 7 deletions(-)
>
> Hello!
>
> I think bzip2 compression of the build logs doesn’t buy us much, it
> doesn’t play well with ‘guix publish’, and bzip2 is generally rather
> uncommon these days—hence this patch.
>
> Thoughts?
>
> Ludo’.

I haven't tried it, but the idea and code LGTM.

Thanks!

Maxim
Ludovic Courtès Jan. 18, 2022, 5:53 p.m. UTC | #2
Maxim Cournoyer <maxim.cournoyer@gmail.com> skribis:

> Ludovic Courtès <ludo@gnu.org> writes:
>
>> * nix/libstore/globals.cc (Settings::Settings): Have 'logCompression'
>> default to COMPRESSION_GZIP unconditionally.
>> * gnu/services/base.scm (<guix-configuration>)[log-compression]: Default
>> to 'gzip.
>> * doc/guix.texi (Invoking guix-daemon, Base Services): Adjust accordingly.
>> ---
>>  doc/guix.texi           | 4 ++--
>>  gnu/services/base.scm   | 2 +-
>>  nix/libstore/globals.cc | 4 ----
>>  3 files changed, 3 insertions(+), 7 deletions(-)
>>
>> Hello!
>>
>> I think bzip2 compression of the build logs doesn’t buy us much, it
>> doesn’t play well with ‘guix publish’, and bzip2 is generally rather
>> uncommon these days—hence this patch.
>>
>> Thoughts?
>>
>> Ludo’.
>
> I haven't tried it, but the idea and code LGTM.

Pushed in 575e52ac2b090fd194086e9c1c53bbf8055acbc2, thanks!

Ludo’.
diff mbox series

Patch

diff --git a/doc/guix.texi b/doc/guix.texi
index 876172fa3a..084d3c92fe 100644
--- a/doc/guix.texi
+++ b/doc/guix.texi
@@ -1690,7 +1690,7 @@  Compress build logs according to @var{type}, one of @code{gzip},
 
 Unless @option{--lose-logs} is used, all the build logs are kept in the
 @var{localstatedir}.  To save space, the daemon automatically compresses
-them with Bzip2 by default.
+them with gzip by default.
 
 @item --discover[=yes|no]
 Whether to discover substitute servers on the local network using mDNS
@@ -16608,7 +16608,7 @@  The number of seconds of silence and the number of seconds of activity,
 respectively, after which a build process times out.  A value of zero
 disables the timeout.
 
-@item @code{log-compression} (default: @code{'bzip2})
+@item @code{log-compression} (default: @code{'gzip})
 The type of compression used for build logs---one of @code{gzip},
 @code{bzip2}, or @code{none}.
 
diff --git a/gnu/services/base.scm b/gnu/services/base.scm
index e46bb591a9..71e2baf959 100644
--- a/gnu/services/base.scm
+++ b/gnu/services/base.scm
@@ -1565,7 +1565,7 @@  (define-record-type* <guix-configuration>
   (timeout          guix-configuration-timeout    ;integer
                     (default 0))
   (log-compression  guix-configuration-log-compression
-                    (default 'bzip2))
+                    (default 'gzip))
   (discover?        guix-configuration-discover?
                     (default #f))
   (extra-options    guix-configuration-extra-options ;list of strings
diff --git a/nix/libstore/globals.cc b/nix/libstore/globals.cc
index 0cc001fbe4..d4f9a46a74 100644
--- a/nix/libstore/globals.cc
+++ b/nix/libstore/globals.cc
@@ -45,11 +45,7 @@  Settings::Settings()
     useChroot = false;
     impersonateLinux26 = false;
     keepLog = true;
-#if HAVE_BZLIB_H
-    logCompression = COMPRESSION_BZIP2;
-#else
     logCompression = COMPRESSION_GZIP;
-#endif
     maxLogSize = 0;
     cacheFailure = false;
     pollInterval = 5;