diff mbox series

[bug#53237] gnu: cryptsetup: Update to 2.3.7 [fixes CVE-2021-4122].

Message ID 8307188193231477efe731752ea56f7cff89dc8d.1642104167.git.leo@famulari.name
State Accepted
Headers show
Series [bug#53237] gnu: cryptsetup: Update to 2.3.7 [fixes CVE-2021-4122]. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Leo Famulari Jan. 13, 2022, 8:02 p.m. UTC
* gnu/packages/cryptsetup.scm (cryptsetup): Update to 2.3.7.
---
 gnu/packages/cryptsetup.scm | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

Comments

Ludovic Courtès Jan. 17, 2022, 6:04 p.m. UTC | #1
Hi,

Leo Famulari <leo@famulari.name> skribis:

> * gnu/packages/cryptsetup.scm (cryptsetup): Update to 2.3.7.

If ‘cryptsetup’ and ‘cryptsetup-static’ both build fine, go for it!

We’ll have to keep an eye on installation tests, too.

Thanks,
Ludo’.
Leo Famulari Jan. 17, 2022, 8:48 p.m. UTC | #2
On Mon, Jan 17, 2022 at 07:04:15PM +0100, Ludovic Courtès wrote:
> Hi,
> 
> Leo Famulari <leo@famulari.name> skribis:
> 
> > * gnu/packages/cryptsetup.scm (cryptsetup): Update to 2.3.7.
> 
> If ‘cryptsetup’ and ‘cryptsetup-static’ both build fine, go for it!
> 
> We’ll have to keep an eye on installation tests, too.

Right. With this change, the system test 'gui-installed-os-encrypted'
still succeeds.

So, I pushed as fc31774747bb274fbf24abdca37dfa1adf698260
diff mbox series

Patch

diff --git a/gnu/packages/cryptsetup.scm b/gnu/packages/cryptsetup.scm
index c8853dca30..d8a6437259 100644
--- a/gnu/packages/cryptsetup.scm
+++ b/gnu/packages/cryptsetup.scm
@@ -35,7 +35,7 @@  (define-module (gnu packages cryptsetup)
 (define-public cryptsetup
   (package
    (name "cryptsetup")
-   (version "2.3.6")
+   (version "2.3.7")
    (source (origin
             (method url-fetch)
             (uri (string-append "mirror://kernel.org/linux/utils/cryptsetup/v"
@@ -43,7 +43,7 @@  (define-public cryptsetup
                                 "/cryptsetup-" version ".tar.xz"))
             (sha256
              (base32
-              "0pv34l6230ba1i5p0z6zmvfqvv3as0cwn731h2qw4xm53sibg5mj"))))
+              "1a97rvi6arsj8dikh1qsvixx9rizm89k155q2ypifqlqllr530v1"))))
    (build-system gnu-build-system)
    (arguments
     `(#:configure-flags