diff mbox series

[bug#52437] Add lifeograph

Message ID 8f43f4093a94b958fe8d65ae731e4b0405e9a01f.camel@courrier.dev
State New
Headers show
Series [bug#52437] Add lifeograph | expand

Commit Message

Pradana Adrinusa AUMARS Dec. 11, 2021, 6:02 p.m. UTC
From 324b8cd3c801ad7c106725aff59fa65d00b50341 Mon Sep 17 00:00:00 2001
From: Pradana AUMARS <paumars@courrier.dev>
Date: Sat, 11 Dec 2021 18:58:51 +0100
Subject: [PATCH] gnu: Add lifeograph.

* gnu/packages/lifeograph.scm (lifeograph): New file.
---
 gnu/packages/lifeograph.scm | 56 +++++++++++++++++++++++++++++++++++++
 1 file changed, 56 insertions(+)
 create mode 100644 gnu/packages/lifeograph.scm

Comments

Nicolas Goaziou Dec. 17, 2021, 8:25 a.m. UTC | #1
Hello,

Pradana Adrinusa AUMARS via Guix-patches via <guix-patches@gnu.org>
writes:

> From 324b8cd3c801ad7c106725aff59fa65d00b50341 Mon Sep 17 00:00:00 2001
> From: Pradana AUMARS <paumars@courrier.dev>
> Date: Sat, 11 Dec 2021 18:58:51 +0100
> Subject: [PATCH] gnu: Add lifeograph.

Thank you. Some comments follow.

> * gnu/packages/lifeograph.scm (lifeograph): New file.

If you create a new file (is in necessary?), you need to also register
it in local.mk file.

> +(define-public rednotebook
> +  (package
> +   (name "lifeograph")

There's a mismatch between the name of the variable and the package.

> +   (version "2.0.2")
> +   (source (origin

Could you move origin below source?

> +            (method url-fetch)
> +            (uri (string-append "https://launchpad.net/" name "/trunk/" version
> +                                "/+download/" name "-" version ".tar.xz"))

You can hard-code "name" above.

> +            (sha256
> +             (base32
> +              "1sfr3fd07x995makdp5wx3lxf7kl156hilliw77d0vnjp8ri49xl"))))

Hash string should go on the same line as base32.

> +   (build-system meson-build-system)
> +   (arguments `(#:build-type "release"))

Could you explain in a comment why "release" is needed?

> +   (inputs
> +    `(("gtkmm" ,gtkmm)
> +      ("gtk+", gtk+ "bin")
> +      ("enchant" ,enchant)
> +      ("libgcrypt" ,libgcrypt)
> +      ("libchamplain" ,libchamplain)))

Could you sort inputs alphabetically? Also could you use new inputs
style:

  (inputs
   (list enchant `(,gtk+ "bin") gtkmm ...))

> +   (native-inputs
> +    `(("pkg-config" ,pkg-config)))

Ditto:

  (native-inputs
   (list pkg-config))

> +   (synopsis "Off-line and private journal and note taking application")
> +   (description "Lifeograph is a diary program to take personal notes on life.
> +It has all the essential functionality expected in a diary program and strives
> +to have a clean and streamlined user interface.")
> +   (home-page "http://lifeograph.sourceforge.net/")
> +   (license license:gpl3+)))

Could you send an updated patch?

Regards,
Josselin Poiret Dec. 17, 2021, 9:13 a.m. UTC | #2
Nicolas Goaziou <mail@nicolasgoaziou.fr> writes:

> Could you sort inputs alphabetically? Also could you use new inputs
> style:

Just chiming in to say that the new input style is documented at
"(guix)package Reference" in the info manual, or at [1].

[1] https://guix.gnu.org/en/blog/2021/the-big-change/

Best,
Josselin Poiret
Pradana Adrinusa AUMARS Dec. 21, 2021, 3:21 p.m. UTC | #3
Hello again,

I think it's better to first rename rednotebook.scm to journal.scm and
add the lifeograph package in that.

So I've written a new patch for that.

https://debbugs.gnu.org/cgi/bugreport.cgi?bug=52704

Thanks.
diff mbox series

Patch

diff --git a/gnu/packages/lifeograph.scm b/gnu/packages/lifeograph.scm
new file mode 100644
index 0000000000..48d419e3b3
--- /dev/null
+++ b/gnu/packages/lifeograph.scm
@@ -0,0 +1,56 @@ 
+;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2021 Pradana Aumars <paumars@courrier.dev>
+;;;
+;;; This file is part of GNU Guix.
+;;;
+;;; GNU Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; GNU Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>;.
+
+(define-module (gnu packages lifeograph)
+  #:use-module (guix packages)
+  #:use-module (guix download)
+  #:use-module (guix build-system meson)
+  #:use-module ((guix licenses) #:prefix license:)
+  #:use-module (gnu packages gtk)
+  #:use-module (gnu packages enchant)
+  #:use-module (gnu packages gnupg)
+  #:use-module (gnu packages gnome)
+  #:use-module (gnu packages pkg-config))
+
+(define-public rednotebook
+  (package
+   (name "lifeograph")
+   (version "2.0.2")
+   (source (origin
+            (method url-fetch)
+            (uri (string-append "https://launchpad.net/" name "/trunk/" version
+                                "/+download/" name "-" version ".tar.xz"))
+            (sha256
+             (base32
+              "1sfr3fd07x995makdp5wx3lxf7kl156hilliw77d0vnjp8ri49xl"))))
+   (build-system meson-build-system)
+   (arguments `(#:build-type "release"))
+   (inputs
+    `(("gtkmm" ,gtkmm)
+      ("gtk+", gtk+ "bin")
+      ("enchant" ,enchant)
+      ("libgcrypt" ,libgcrypt)
+      ("libchamplain" ,libchamplain)))
+   (native-inputs
+    `(("pkg-config" ,pkg-config)))
+   (synopsis "Off-line and private journal and note taking application")
+   (description "Lifeograph is a diary program to take personal notes on life.
+It has all the essential functionality expected in a diary program and strives
+to have a clean and streamlined user interface.")
+   (home-page "http://lifeograph.sourceforge.net/")
+   (license license:gpl3+)))