diff mbox series

[bug#51511] gnu: Add r-xmapbridge.

Message ID 20211030142035.25460-1-madalinionel.patrascu@mdc-berlin.de
State Accepted
Headers show
Series [bug#51511] gnu: Add r-xmapbridge. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Mădălin Ionel Patrașcu Oct. 30, 2021, 2:20 p.m. UTC
* gnu/packages/bioconductor.scm (r-xmapbridge): New variable.
---
 gnu/packages/bioconductor.scm | 27 +++++++++++++++++++++++++++
 1 file changed, 27 insertions(+)

Comments

Ricardo Wurmus Nov. 27, 2021, 9:44 a.m. UTC | #1
Mădălin Ionel Patrașcu <madalinionel.patrascu@mdc-berlin.de> 
writes:

> * gnu/packages/bioconductor.scm (r-xmapbridge): New variable.

Applied, thank you!
diff mbox series

Patch

diff --git a/gnu/packages/bioconductor.scm b/gnu/packages/bioconductor.scm
index 90a0e1f288..24ab4897d5 100644
--- a/gnu/packages/bioconductor.scm
+++ b/gnu/packages/bioconductor.scm
@@ -4627,6 +4627,33 @@  (define-public r-vsn
 and specific in detecting differential transcription.")
     (license license:artistic2.0)))
 
+(define-public r-xmapbridge
+  (package
+    (name "r-xmapbridge")
+    (version "1.52.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (bioconductor-uri "xmapbridge" version))
+       (sha256
+        (base32 "1zsqhisbq6f9qgw9f0a6ixxh635h3qm17117yfns5nnfw73ndlgi"))))
+    (properties `((upstream-name . "xmapbridge")))
+    (build-system r-build-system)
+    (home-page "https://git.bioconductor.org/packages/xmapbridge")
+    (synopsis "Display numeric data in the web based genome browser X:MAP")
+    (description
+     "The package @code{r-xmapBridge} can plot graphs in the X:Map genome
+browser.  X:Map uses the Google Maps API to provide a scrollable view of the
+genome.  It supports a number of species, and can be accessed at
+http://xmap.picr.man.ac.uk.  This package exports plotting files in a suitable
+format.  Graph plotting in R is done using calls to the functions
+@code{xmap.plot} and @code{xmap.points}, which have parameters that aim to be
+similar to those used by the standard plot methods in R.  These result in data
+being written to a set of files (in a specific directory structure) that
+contain the data to be displayed, as well as some additional meta-data
+describing each of the graphs.")
+    (license license:lgpl3)))
+
 (define-public r-xvector
   (package
     (name "r-xvector")