diff mbox series

[bug#50757,v2] gnu: Add babeltrace.

Message ID e7d66e7c057ec525488578aec8853c730a14a04f.1637519461.git.olivier.dion@polymtl.ca
State Accepted
Headers show
Series [bug#50757,v2] gnu: Add babeltrace. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Olivier Dion Nov. 21, 2021, 6:31 p.m. UTC
* gnu/packages/linux.scm (babeltrace): New variable.
---
 gnu/packages/linux.scm | 56 ++++++++++++++++++++++++++++++++++++++++++
 1 file changed, 56 insertions(+)

Comments

Maxim Cournoyer Nov. 22, 2021, 2:31 a.m. UTC | #1
Hey Olivier!

Olivier Dion <olivier.dion@polymtl.ca> writes:

> * gnu/packages/linux.scm (babeltrace): New variable.
> ---
>  gnu/packages/linux.scm | 56 ++++++++++++++++++++++++++++++++++++++++++
>  1 file changed, 56 insertions(+)
>
> diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
> index 4d167dc522..81589955cc 100644
> --- a/gnu/packages/linux.scm
> +++ b/gnu/packages/linux.scm
> @@ -131,6 +131,7 @@ (define-module (gnu packages linux)
>    #:use-module (gnu packages sdl)
>    #:use-module (gnu packages serialization)
>    #:use-module (gnu packages slang)
> +  #:use-module (gnu packages sphinx)
>    #:use-module (gnu packages sqlite)
>    #:use-module (gnu packages texinfo)
>    #:use-module (gnu packages tls)
> @@ -8199,6 +8200,61 @@ (define-public lttng-tools
>  @code{lttng-relayd} for network streaming.")
>      (license (list  license:gpl2 license:lgpl2.1))))
>  
> +(define-public babeltrace
> +  (package
> +    (name "babeltrace")
> +    (version "2.0.4")
> +    (source (origin
> +              (method url-fetch)
> +              (uri (string-append "https://www.efficios.com/files/babeltrace/babeltrace2-"
> +                                  version ".tar.bz2"))
> +              (sha256
> +               (base32 "1jlv925pr7hykc48mdvbmqm4ipy1r11xwzapa6fdpdfshmk12kvp"))))
> +
> +    (build-system gnu-build-system)
> +
> +    (arguments
> +     `(;; FIXME - When Python's bindings are enabled, tests do not pass.
> +       #:configure-flags '("--enable-debug-info"
> +                           "--enable-man-pages"
> +                           "--disable-python-bindings"
> +                           "--disable-python-plugins")
> +       #:phases
> +       (modify-phases %standard-phases
> +         ;; These are recommended in the project's README for a development
> +         ;; build configuration.
> +         (add-before 'configure 'set-environment-variables
> +           (lambda _
> +             (setenv "BABELTRACE_DEV_MODE" "1")
> +             (setenv "BABELTRACE_MINIMAL_LOG_LEVEL" "TRACE"))))))
> +    (inputs
> +     `(("glib" ,glib)))
> +    ;; NOTE - elfutils is used for the LTTng debug information filter
> +    ;; component class.  This can be moved to `native-inputs` if
> +    ;; `--enable-debug-info` is replaced by `--disable-debug-info` in
> +    ;; `#:configure-flags`.
> +    (propagated-inputs
> +     `(("elfutils" ,elfutils)))
> +    ;; NOTE - python-3 is set here for generating the bindings.  Users need to
> +    ;; install python-3 in their profile in order to use these bindings.
> +    (native-inputs
> +     `(("asciidoc" ,asciidoc)
> +       ("bison" ,bison)
> +       ("flex" ,flex)
> +       ("pkg-config" ,pkg-config)
> +       ("python-3" ,python-3)
> +       ("python-sphinx" ,python-sphinx)
> +       ("swig", swig)
> +       ("xmltoman" ,xmltoman)))
> +    (home-page "https://babeltrace.org/")
> +    (synopsis "Trace manipulation toolkit")
> +    (description "Babeltrace 2 is a framework for viewing, converting,
> +transforming, and analyzing traces.  It is also the reference parser
> +implementation of the Common Trace Format (CTF), produced by tools such as
> +LTTng and barectf.  This package provides a library with a C API, Python 3
> +bindings, and the command-line tool @command{babeltrace2}.")
> +    (license license:expat)))
> +
>  (define-public kexec-tools
>    (package
>      (name "kexec-tools")

Thanks for this, and to Sarah for the nice review!

I've pushed this as-is to master as
82f8ac4c291e80ef94ee57ff1e0f62f1307c0afb.

Happy hacking!

Maxim
diff mbox series

Patch

diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 4d167dc522..81589955cc 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -131,6 +131,7 @@  (define-module (gnu packages linux)
   #:use-module (gnu packages sdl)
   #:use-module (gnu packages serialization)
   #:use-module (gnu packages slang)
+  #:use-module (gnu packages sphinx)
   #:use-module (gnu packages sqlite)
   #:use-module (gnu packages texinfo)
   #:use-module (gnu packages tls)
@@ -8199,6 +8200,61 @@  (define-public lttng-tools
 @code{lttng-relayd} for network streaming.")
     (license (list  license:gpl2 license:lgpl2.1))))
 
+(define-public babeltrace
+  (package
+    (name "babeltrace")
+    (version "2.0.4")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append "https://www.efficios.com/files/babeltrace/babeltrace2-"
+                                  version ".tar.bz2"))
+              (sha256
+               (base32 "1jlv925pr7hykc48mdvbmqm4ipy1r11xwzapa6fdpdfshmk12kvp"))))
+
+    (build-system gnu-build-system)
+
+    (arguments
+     `(;; FIXME - When Python's bindings are enabled, tests do not pass.
+       #:configure-flags '("--enable-debug-info"
+                           "--enable-man-pages"
+                           "--disable-python-bindings"
+                           "--disable-python-plugins")
+       #:phases
+       (modify-phases %standard-phases
+         ;; These are recommended in the project's README for a development
+         ;; build configuration.
+         (add-before 'configure 'set-environment-variables
+           (lambda _
+             (setenv "BABELTRACE_DEV_MODE" "1")
+             (setenv "BABELTRACE_MINIMAL_LOG_LEVEL" "TRACE"))))))
+    (inputs
+     `(("glib" ,glib)))
+    ;; NOTE - elfutils is used for the LTTng debug information filter
+    ;; component class.  This can be moved to `native-inputs` if
+    ;; `--enable-debug-info` is replaced by `--disable-debug-info` in
+    ;; `#:configure-flags`.
+    (propagated-inputs
+     `(("elfutils" ,elfutils)))
+    ;; NOTE - python-3 is set here for generating the bindings.  Users need to
+    ;; install python-3 in their profile in order to use these bindings.
+    (native-inputs
+     `(("asciidoc" ,asciidoc)
+       ("bison" ,bison)
+       ("flex" ,flex)
+       ("pkg-config" ,pkg-config)
+       ("python-3" ,python-3)
+       ("python-sphinx" ,python-sphinx)
+       ("swig", swig)
+       ("xmltoman" ,xmltoman)))
+    (home-page "https://babeltrace.org/")
+    (synopsis "Trace manipulation toolkit")
+    (description "Babeltrace 2 is a framework for viewing, converting,
+transforming, and analyzing traces.  It is also the reference parser
+implementation of the Common Trace Format (CTF), produced by tools such as
+LTTng and barectf.  This package provides a library with a C API, Python 3
+bindings, and the command-line tool @command{babeltrace2}.")
+    (license license:expat)))
+
 (define-public kexec-tools
   (package
     (name "kexec-tools")