diff mbox series

[bug#52005,core-updates-frozen] gnu: emacs-xwidgets/-next-pgtk: Replace webkitgtk with webkitgtk-with-libsoup2.

Message ID zVQzP9bHdO_a5VJMh0W_u5ceaECKyFowDlbeffRkMtgTrff9pKNHhsy09y0mKwrKoVMgn-mMqhaOLBh7gbmG7MqOLRxqFQj1gyRSBMVyUjM=@protonmail.com
State Accepted
Headers show
Series [bug#52005,core-updates-frozen] gnu: emacs-xwidgets/-next-pgtk: Replace webkitgtk with webkitgtk-with-libsoup2. | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

John Kehayias Nov. 20, 2021, 7:16 p.m. UTC
Hello,

Emacs with xwidgets support needs webkit2gtk-4.0, which for us means the variant built with libsoup2 on core-updates-frozen. I've changed the inputs in the two affected Emacs packages and added to the comment about where webkitgtk-with-libsoup2 is used. Apologies if the formatting/style of the commit message is off, wasn't sure how best to do this.

John

Comments

Tobias Geerinckx-Rice Nov. 21, 2021, 3:44 p.m. UTC | #1
John,

Pushed with some minor changes as 
85de88f1adcf5b91afe76bf671c05b8596821920:

- Removed copyright lines.
- Edited commit message a bit:
  - Wrapped to 72 characters, the git (or Linux?) convention
  - Shortened title as well: we often exceed the conventional 50 
  characters, but try to keep it short still
  - Wrote ‘{,-next-pgtk}’: valid variable names like 
  ‘foo-tools/static’ exist
  - Wrote ‘(var1, var2)’ instead of ‘(var1 and var2)’.

Thanks!

T G-R
diff mbox series

Patch

From 17dd0a5748bc4a984393812e395e88c6060cbf55 Mon Sep 17 00:00:00 2001
From: John Kehayias <john.kehayias@protonmail.com>
Date: Sat, 20 Nov 2021 14:03:08 -0500
Subject: [PATCH] gnu: emacs-xwidgets/-next-pgtk: Replace webkitgtk with
 webkitgtk-with-libsoup2.

* gnu/packages/emacs.scm (emacs-xwidgets and emacs-next-pgtk)[inputs]: Replace
webkitgtk with webkitgtk-with-libsoup2.
* gnu/packages/webkit.scm (webkitgtk-with-libsoup2): Add further information
about where this package is used and upstream tracker for libsoup3.
---
 gnu/packages/emacs.scm  | 4 ++--
 gnu/packages/webkit.scm | 3 +++
 2 files changed, 5 insertions(+), 2 deletions(-)

diff --git a/gnu/packages/emacs.scm b/gnu/packages/emacs.scm
index 734f3dfaa3..fbd9ff96f0 100644
--- a/gnu/packages/emacs.scm
+++ b/gnu/packages/emacs.scm
@@ -354,7 +354,7 @@  (define-public emacs-next-pgtk
        `(("gsettings-desktop-schemas" ,gsettings-desktop-schemas)
          ("glib-networking" ,glib-networking)))
       (inputs
-       `(("webkitgtk" ,webkitgtk)
+       `(("webkitgtk" ,webkitgtk-with-libsoup2)
          ,@(package-inputs emacs-next)))
       (home-page "https://github.com/masm11/emacs")
       (synopsis "Emacs text editor with @code{pgtk} and @code{xwidgets} support")
@@ -400,7 +400,7 @@  (define-public emacs-xwidgets
            (delete 'restore-emacs-pdmp)
            (delete 'strip-double-wrap)))))
     (inputs
-     `(("webkitgtk" ,webkitgtk)
+     `(("webkitgtk" ,webkitgtk-with-libsoup2)
        ("libxcomposite" ,libxcomposite)
        ,@(package-inputs emacs)))))
 
diff --git a/gnu/packages/webkit.scm b/gnu/packages/webkit.scm
index 5230129158..f988bf0697 100644
--- a/gnu/packages/webkit.scm
+++ b/gnu/packages/webkit.scm
@@ -364,6 +364,9 @@  (define-public webkitgtk
 
 ;;; Required by gnome-online-accounts; as webkitgtk 2.34 propagates libsoup 3,
 ;;; which causes the build to fail.
+;;; Also required by e.g. emacs-next-pgtk,  emacs-xwidgets, and some other
+;;; Gnome packages for webkit2gtk-4.0. See also the upstream tracker for
+;;; libsoup 3: https://gitlab.gnome.org/GNOME/libsoup/-/issues/218
 (define-public webkitgtk-with-libsoup2
   (package/inherit webkitgtk
     (name "webkitgtk-with-libsoup2")
-- 
2.34.0