diff mbox series

[bug#51967] gnu: Add gsimplecal

Message ID DM6PR19MB2460CFD233783E88E8223F6E999D9@DM6PR19MB2460.namprd19.prod.outlook.com
State Accepted
Headers show
Series [bug#51967] gnu: Add gsimplecal | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Wamm K. D Nov. 20, 2021, 11:38 p.m. UTC
* gnu/packages/calendar.scm (gsimplecal): New variable
---
gnu/packages/calendar.scm | 30 ++++++++++++++++++++++++++++++
1 file changed, 30 insertions(+)

 diff --git a/gnu/packages/calendar.scm b/gnu/packages/calendar.scm
index 8ec36d4fa2..9ffdbaa85e 100644

Comments

Liliana Marie Prikler Nov. 21, 2021, 8:46 a.m. UTC | #1
I've applied the patch with some minor adjustments and pushed it.
Note that Outlook messes up the mail quite a lot, inserting non-
breakable spaces instead of clean ones wherever it wants to.  You might
want to configure it so as to not do that.

Cheers

Am Samstag, den 20.11.2021, 23:38 +0000 schrieb Jaft:
> * gnu/packages/calendar.scm (gsimplecal): New variable
> ---
> gnu/packages/calendar.scm | 30 ++++++++++++++++++++++++++++++
> 1 file changed, 30 insertions(+)
> 
>  diff --git a/gnu/packages/calendar.scm b/gnu/packages/calendar.scm
> index 8ec36d4fa2..9ffdbaa85e 100644
> --- a/gnu/packages/calendar.scm
> +++ b/gnu/packages/calendar.scm
> @@ -10,6 +10,7 @@
>  ;;; Copyright © 2020 Brendan Tildesley <mail@brendan.scot>
>  ;;; Copyright © 2020 Tanguy Le Carrour <tanguy@bioneland.org>
>  ;;; Copyright © 2020 Peng Mei Yu <pengmeiyu@riseup.net>
> +;;; Copyright © 2021 Wamm K. D. <jaft.r@outlook.com>
>  ;;;
>  ;;; This file is part of GNU Guix.
>  ;;;
> @@ -36,6 +37,7 @@ (define-module (gnu packages calendar)
>    #:use-module (guix build-system cmake)
>    #:use-module (guix build-system python)
>    #:use-module (gnu packages admin)
> +  #:use-module (gnu packages autotools)
>    #:use-module (gnu packages base)
>    #:use-module (gnu packages check)
>    #:use-module (gnu packages dav)
> @@ -405,3 +407,31 @@ (define-public ccal
>      ;; COPYING.LESSER specifies LGPL 3.0, but all source files say
>      ;; 'Lesser GPL version 2 or later'.
>      (license (list license:gpl2+ license:lgpl2.1+))))
> +
> +(define-public gsimplecal
> +  (let ((version "2.2"))
> +    (package
> +      (name "gsimplecal")
> +      (version version)
> +      (source (origin
> +                (method git-fetch)
> +                (uri (git-reference
> +                      (url "
> https://github.com/dmedvinsky/gsimplecal/")
> +                      (commit (string-append "v" version))))
> +                (file-name (git-file-name name version))
> +                (sha256 (base32
> +                       
>  "1qyf65l088dqsz25hm6s1cv18j52yaias0llqvpqwjfnvssa5cxg"))
> +                (modules '((guix build utils)))))
> +      (build-system gnu-build-system)
> +      (inputs `(("gtk+" ,gtk+)))
> +      (native-inputs
> +       `(("autoconf" ,autoconf)
> +         ("automake" ,automake)
> +         ("pkg-config" ,pkg-config)))
> +      (home-page "https://dmedvinsky.github.io/gsimplecal/")
> +      (synopsis "Lightweight calendar applet written in C++ using
> GTK")
> +      (description "Gsimplecal is a lightweight calendar application
> written in
> +C++ using GTK.  Launched once, it pops up a small calendar applet,
> launched
> +again it closes the running instance.  It can additionally be
> configured to show
> +the current time in different timezones.")
> +      (license license:bsd-3))))
Liliana Marie Prikler Nov. 21, 2021, 8:55 a.m. UTC | #2
Forgot to mark as done.
diff mbox series

Patch

--- a/gnu/packages/calendar.scm
+++ b/gnu/packages/calendar.scm
@@ -10,6 +10,7 @@ 
 ;;; Copyright © 2020 Brendan Tildesley <mail@brendan.scot>
 ;;; Copyright © 2020 Tanguy Le Carrour <tanguy@bioneland.org>
 ;;; Copyright © 2020 Peng Mei Yu <pengmeiyu@riseup.net>
+;;; Copyright © 2021 Wamm K. D. <jaft.r@outlook.com>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -36,6 +37,7 @@  (define-module (gnu packages calendar)
   #:use-module (guix build-system cmake)
   #:use-module (guix build-system python)
   #:use-module (gnu packages admin)
+  #:use-module (gnu packages autotools)
   #:use-module (gnu packages base)
   #:use-module (gnu packages check)
   #:use-module (gnu packages dav)
@@ -405,3 +407,31 @@  (define-public ccal
     ;; COPYING.LESSER specifies LGPL 3.0, but all source files say
     ;; 'Lesser GPL version 2 or later'.
     (license (list license:gpl2+ license:lgpl2.1+))))
+
+(define-public gsimplecal
+  (let ((version "2.2"))
+    (package
+      (name "gsimplecal")
+      (version version)
+      (source (origin
+                (method git-fetch)
+                (uri (git-reference
+                      (url "https://github.com/dmedvinsky/gsimplecal/")
+                      (commit (string-append "v" version))))
+                (file-name (git-file-name name version))
+                (sha256 (base32
+                         "1qyf65l088dqsz25hm6s1cv18j52yaias0llqvpqwjfnvssa5cxg"))
+                (modules '((guix build utils)))))
+      (build-system gnu-build-system)
+      (inputs `(("gtk+" ,gtk+)))
+      (native-inputs
+       `(("autoconf" ,autoconf)
+         ("automake" ,automake)
+         ("pkg-config" ,pkg-config)))
+      (home-page "https://dmedvinsky.github.io/gsimplecal/")
+      (synopsis "Lightweight calendar applet written in C++ using GTK")
+      (description "Gsimplecal is a lightweight calendar application written in
+C++ using GTK.  Launched once, it pops up a small calendar applet, launched
+again it closes the running instance.  It can additionally be configured to show
+the current time in different timezones.")
+      (license license:bsd-3))))