diff mbox series

[bug#51913] gnu: Add cl-binascii.

Message ID PU1PR01MB21552C6186FA4DD41C92E7428D9A9@PU1PR01MB2155.apcprd01.prod.exchangelabs.com
State Accepted
Headers show
Series [bug#51913] gnu: Add cl-binascii. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Foo Chuan Wei Nov. 17, 2021, 5:40 a.m. UTC
* gnu/packages/lisp-xyz.scm (cl-binascii, ecl-binascii, sbcl-binascii):
  New variables.
---
 gnu/packages/lisp-xyz.scm | 34 ++++++++++++++++++++++++++++++++++
 1 file changed, 34 insertions(+)


base-commit: 02a67810e566e8402e0b927c81ae39391762767d

Comments

Foo Chuan Wei Nov. 18, 2021, 6:04 a.m. UTC | #1
There are a few problems with this patch:
* Tests are failing on ECL.
* It bundles rt.lisp, which should be unbundled (use Guix's cl-rt
  instead).
Guillaume Le Vaillant Nov. 20, 2021, 2:02 p.m. UTC | #2
Foo Chuan Wei <chuanwei.foo@hotmail.com> skribis:

> There are a few problems with this patch:
> * Tests are failing on ECL.
> * It bundles rt.lisp, which should be unbundled (use Guix's cl-rt
>   instead).

Concerning rt, I thing adding a snippet deleting "tests/rt.lisp" and
modifying the definition of "binascii-tests" in "binascii.asd" (removing
the references to the rt file and adding the rt system in the
"depends-on" list) should work.
Ludovic Courtès Dec. 10, 2021, 2:20 p.m. UTC | #3
Ping! :-)

Guillaume Le Vaillant <glv@posteo.net> skribis:

> Foo Chuan Wei <chuanwei.foo@hotmail.com> skribis:
>
>> There are a few problems with this patch:
>> * Tests are failing on ECL.
>> * It bundles rt.lisp, which should be unbundled (use Guix's cl-rt
>>   instead).
>
> Concerning rt, I thing adding a snippet deleting "tests/rt.lisp" and
> modifying the definition of "binascii-tests" in "binascii.asd" (removing
> the references to the rt file and adding the rt system in the
> "depends-on" list) should work.
Guillaume Le Vaillant Sept. 5, 2022, 12:09 p.m. UTC | #4
Ludovic Courtès <ludo@gnu.org> skribis:

> Ping! :-)
>
> Guillaume Le Vaillant <glv@posteo.net> skribis:
>
>> Foo Chuan Wei <chuanwei.foo@hotmail.com> skribis:
>>
>>> There are a few problems with this patch:
>>> * Tests are failing on ECL.
>>> * It bundles rt.lisp, which should be unbundled (use Guix's cl-rt
>>>   instead).
>>
>> Concerning rt, I thing adding a snippet deleting "tests/rt.lisp" and
>> modifying the definition of "binascii-tests" in "binascii.asd" (removing
>> the references to the rt file and adding the rt system in the
>> "depends-on" list) should work.

I unbundled RT and pushed as 0f88acb9fa8f7bbdfb2a647907fe63b1974ab824
without the ecl-binascii variant, as it looks like the library doesn't
work with ECL.
diff mbox series

Patch

diff --git a/gnu/packages/lisp-xyz.scm b/gnu/packages/lisp-xyz.scm
index 4b17c173c9..39325d2f6b 100644
--- a/gnu/packages/lisp-xyz.scm
+++ b/gnu/packages/lisp-xyz.scm
@@ -17879,6 +17879,40 @@  RSS feeds data via HTTP.  Currently, it supports RSS versions 0.90,
 (define-public cl-rss
   (sbcl-package->cl-source-package sbcl-rss))
 
+(define-public sbcl-binascii
+  (let ((commit "0fb0a9e5773148fd04d50efef08c1cc10f6fc487")
+        (revision "1"))
+    (package
+      (name "sbcl-binascii")
+      (version (git-version "1.0" revision commit))
+      (source
+       (origin
+         (method git-fetch)
+         (uri (git-reference
+               (url "https://github.com/froydnj/binascii")
+               (commit commit)))
+         (file-name (git-file-name "cl-binascii" version))
+         (sha256
+          (base32 "000rcdl8qshr7n48zq9bzrc4lkjx4ylb3r3w9x9syhiwfla9j4b7"))))
+      (build-system asdf-build-system/sbcl)
+      (home-page "https://github.com/froydnj/binascii")
+      (synopsis "Common Lisp library of ASCII encoding schemes for binary data")
+      (description
+       "@code{binascii} is a Common Lisp library for converting binary data
+to ASCII text of some kind.  Such conversions are common in email protocols
+(for encoding attachments to support old non-8-bit clean transports) or
+encoding binary data in HTTP and XML applications.  @code{binascii} supports
+the encodings described in RFC 4648: base64, base32, base16, and variants.
+It also supports base85, used in Adobe's PostScript and PDF document formats,
+and a variant called ascii85, used by git for binary diff files.")
+      (license license:bsd-3))))
+
+(define-public cl-binascii
+  (sbcl-package->cl-source-package sbcl-binascii))
+
+(define-public ecl-binascii
+  (sbcl-package->ecl-package sbcl-binascii))
+
 (define-public sbcl-trivial-with-current-source-form
   (let ((commit "9e343e043a77a5478c1f77bb626db22335fbbfb8")
         (revision "1"))