diff mbox series

[bug#51625,v2] gnu: Add rcs-blame.

Message ID PU1PR01MB2155090268AA7BE8FA0366438D999@PU1PR01MB2155.apcprd01.prod.exchangelabs.com
State Accepted
Headers show
Series [bug#51625,v2] gnu: Add rcs-blame. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Foo Chuan Wei Nov. 16, 2021, 1:54 a.m. UTC
* gnu/packages/version-control.scm (rcs-blame): New variable.
---
Changes relative to PATCH v1:
* Fix indentation of package definition.

 gnu/packages/version-control.scm | 22 ++++++++++++++++++++++
 1 file changed, 22 insertions(+)


base-commit: 122396075f12b013b6bde56dafb895587b95bc9d

Comments

Ludovic Courtès Nov. 17, 2021, 5:20 p.m. UTC | #1
Foo Chuan Wei <chuanwei.foo@hotmail.com> skribis:

> * gnu/packages/version-control.scm (rcs-blame): New variable.

Applied, thanks!

Ludo’.
diff mbox series

Patch

diff --git a/gnu/packages/version-control.scm b/gnu/packages/version-control.scm
index 00a8be49f9..ee8f409940 100644
--- a/gnu/packages/version-control.scm
+++ b/gnu/packages/version-control.scm
@@ -41,6 +41,7 @@ 
 ;;; Copyright © 2021 François J. <francois-oss@avalenn.eu>
 ;;; Copyright © 2021 Julien Lepiller <julien@lepiller.eu>
 ;;; Copyright © 2021 jgart <jgart@dismail.de>
+;;; Copyright © 2021 Foo Chuan Wei <chuanwei.foo@hotmail.com>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -2060,6 +2061,27 @@  administration files, for example, which are often inherently local to one
 machine.")
     (license license:gpl3+)))
 
+(define-public rcs-blame
+  (package
+    (name "rcs-blame")
+    (version "1.3.1-20210207")
+    (source (origin
+             (method url-fetch)
+             (uri (string-append
+                   "https://invisible-mirror.net/archives/rcs-blame/blame-"
+                   version ".tgz"))
+             (sha256
+              (base32
+               "1j0brsvdx3hlbwchddafh8r2xmxv5vg4ahpd68v4bb9xhcq6pcih"))))
+    (build-system gnu-build-system)
+    (home-page "https://invisible-island.net/rcs-blame/rcs-blame.html")
+    (synopsis "Display the last modification for each line in an RCS file")
+    (description
+     "@code{blame} outputs an annotated revision from each RCS file.  An
+annotated RCS file describes the revision and date in which each line was
+added to the file, and the author of each line.")
+    (license license:gpl2+)))
+
 (define-public cvs
   (package
     (name "cvs")