diff mbox series

[bug#51861,v2,3/3] gnu: Add cl-chemboy.

Message ID PU1PR01MB21559FBA357A5A0B2F963CB48D989@PU1PR01MB2155.apcprd01.prod.exchangelabs.com
State Accepted
Headers show
Series None | expand

Commit Message

Foo Chuan Wei Nov. 15, 2021, 8:22 a.m. UTC
* gnu/packages/lisp-xyz.scm (cl-chemboy, ecl-chemboy, sbcl-chemboy):
  New variables.
---
Changes relative to PATCH v1:
* Use HTTPS to download source tarball.

 gnu/packages/lisp-xyz.scm | 48 +++++++++++++++++++++++++++++++++++++++
 1 file changed, 48 insertions(+)

Comments

Guillaume Le Vaillant Nov. 15, 2021, 4:53 p.m. UTC | #1
Patches pushed as 333e1b3ce670d257c5aee4ed2b9303992aeeaa69 and
following.
Thanks.
diff mbox series

Patch

diff --git a/gnu/packages/lisp-xyz.scm b/gnu/packages/lisp-xyz.scm
index f5798a68de..c7883c164f 100644
--- a/gnu/packages/lisp-xyz.scm
+++ b/gnu/packages/lisp-xyz.scm
@@ -18750,6 +18750,54 @@  could just install the chemical-compounds package.")
 (define-public ecl-chemical-compounds
   (sbcl-package->ecl-package sbcl-chemical-compounds))
 
+(define-public sbcl-chemboy
+  (package
+    (name "sbcl-chemboy")
+    (version "0.3")
+    (source
+      (origin
+        (method url-fetch)
+        (uri (string-append
+              "https://common-lisp.net/project/chemboy/chemboy-"
+              version ".tar.gz"))
+        (sha256
+         (base32
+          "0lr134l16mjcgdj3fm2yff4chlfbihn1sji7q80y7lnr176zgs7d"))))
+    (build-system asdf-build-system/sbcl)
+    (inputs `(("chemical-compounds" ,sbcl-chemical-compounds)
+              ("periodic-table" ,sbcl-periodic-table)))
+    (arguments `(#:phases
+                 (modify-phases %standard-phases
+                   (add-after 'unpack 'fix-files
+                     (lambda _
+                       ;; Fix incorrect version number.
+                       (substitute* "chemboy.asd"
+                         ((":version \"0.2\"")
+                          (string-append ":version \"" ,version "\"")))
+                       ;; Remove incorrect declaration of string type.
+                       (substitute* "query-parsing.lisp"
+                         (("\\(declare \\(simple-base-string string\\)")
+                          "(declare"))
+                       ;; Fix incorrect function calls.
+                       (substitute* "conversions.lisp"
+                         (("\\(pprint-compound element s\\)")
+                          "(pprint-compound element :stream s)")
+                         (("\\(pprint-compound parsed-compound s\\)")
+                          "(pprint-compound parsed-compound :stream s)"))
+                       #t)))))
+    (home-page "https://common-lisp.net/project/chemboy/")
+    (synopsis "Common Lisp program for doing basic chemistry calculations")
+    (description
+     "Chemboy is a Common Lisp program for doing basic chemistry calculations.
+This package provides the text-based interface for Chemboy.")
+    (license license:llgpl)))
+
+(define-public cl-chemboy
+  (sbcl-package->cl-source-package sbcl-chemboy))
+
+(define-public ecl-chemboy
+  (sbcl-package->ecl-package sbcl-chemboy))
+
 (define-public sbcl-cl-pass
   (let ((commit "e58e97c0c0588dc742c061208afb9bc31e4dbd34")
         (revision "1"))