diff mbox series

[bug#51617] gnu: alot: Disable hanging test.

Message ID 20211105173156.16431-1-tanguy@bioneland.org
State Accepted
Headers show
Series [bug#51617] gnu: alot: Disable hanging test. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Tanguy LE CARROUR Nov. 5, 2021, 5:31 p.m. UTC
* gnu/packages/mail.scm (alot) [#:phases]: Disable hanging test.
---
 gnu/packages/mail.scm | 4 ++++
 1 file changed, 4 insertions(+)

Comments

Ludovic Courtès Nov. 14, 2021, 10:15 p.m. UTC | #1
Hi,

Tanguy Le Carrour <tanguy@bioneland.org> skribis:

> * gnu/packages/mail.scm (alot) [#:phases]: Disable hanging test.

Applied, thanks!

Ludo’.
Tanguy LE CARROUR Nov. 15, 2021, 7:59 a.m. UTC | #2
Hi,


Excerpts from Ludovic Courtès's message of November 14, 2021 11:15 pm:
> Tanguy Le Carrour <tanguy@bioneland.org> skribis:
> 
>> * gnu/packages/mail.scm (alot) [#:phases]: Disable hanging test.
> 
> Applied, thanks!

Thanks!
diff mbox series

Patch

diff --git a/gnu/packages/mail.scm b/gnu/packages/mail.scm
index ca748bff1b..87971bafc7 100644
--- a/gnu/packages/mail.scm
+++ b/gnu/packages/mail.scm
@@ -1272,6 +1272,10 @@  (define-public alot
           (substitute* "tests/commands/test_global.py"
             (("def test_no_spawn_no_stdin_attached")
              "def _test_no_spawn_no_stdin_attached"))
+          ;; FIXME: Investigate why this test hangs.
+          (substitute* "tests/db/test_manager.py"
+            (("def test_save_named_query")
+             "def _test_save_named_query"))
           #t)))))
     (native-inputs
      `(("procps" ,procps)