diff mbox series

[bug#51675,4/5] gnu: Add python-towncrier.

Message ID 20211108024520.49594-4-singpolyma@singpolyma.net
State New
Headers show
Series [bug#51675,1/5] gnu: python-incremental: Update to 21.3.0 | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Stephen Paul Weber Nov. 8, 2021, 2:45 a.m. UTC
* gnu/packages/python-xyz.scm (python-towncrier): New variable.
---
 gnu/packages/python-xyz.scm | 26 ++++++++++++++++++++++++++
 1 file changed, 26 insertions(+)

Comments

Vinicius Monego Nov. 12, 2021, 6:06 p.m. UTC | #1
Em dom, 2021-11-07 às 21:45 -0500, Stephen Paul Weber escreveu:
> * gnu/packages/python-xyz.scm (python-towncrier): New variable.
> ---
>  gnu/packages/python-xyz.scm | 26 ++++++++++++++++++++++++++
>  1 file changed, 26 insertions(+)
> 
> diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-
> xyz.scm
> index f439ffd91e..4305e06030 100644
> --- a/gnu/packages/python-xyz.scm
> +++ b/gnu/packages/python-xyz.scm
> @@ -27731,3 +27731,29 @@ hierarchies and, as it aims at documenting
> Twisted, knows about zope.interface's
>  declaration API and can present information about which classes
> implement which
>  interface, and vice versa.")
>      (license license:expat)))
> +
> +(define-public python-towncrier
> +  (package
> +    (name "python-towncrier")
> +    (version "21.3.0")
> +    (source
> +      (origin
> +        (method url-fetch)
> +        (uri (pypi-uri "towncrier" version))
> +        (sha256
> +          (base32
> "1znxavwsiy6czirjn0qi1p5yarnm7gg692nb0309hb6p4k4hpvbf"))))
> +    (build-system python-build-system)
> +    (propagated-inputs
> +      `(("python-click" ,python-click)
> +        ("python-click-default-group" ,python-click-default-group)
> +        ("python-incremental" ,python-incremental)
> +        ("python-jinja2" ,python-jinja2)
> +        ("python-toml" ,python-toml)))
> +    (native-inputs `(("python-packaging" ,python-packaging)))
> +    (home-page "https://github.com/hawkowl/towncrier")
> +    (synopsis "Tool to build newsfiles for your Python project")
> +    (description "A utility to produce useful, summarised news files
> for your
> +project. Rather than reading the Git history as some newer tools to
> produce it,
> +or having one single file which developers all write to, towncrier
> reads
> +\"news fragments\" which contain information useful to end users.")

Full sentence in description. New sentences have to be started with
double spaces. You can check for linting issues with the `guix lint`
tool.

> +    (license license:expat)))
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index f439ffd91e..4305e06030 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -27731,3 +27731,29 @@  hierarchies and, as it aims at documenting Twisted, knows about zope.interface's
 declaration API and can present information about which classes implement which
 interface, and vice versa.")
     (license license:expat)))
+
+(define-public python-towncrier
+  (package
+    (name "python-towncrier")
+    (version "21.3.0")
+    (source
+      (origin
+        (method url-fetch)
+        (uri (pypi-uri "towncrier" version))
+        (sha256
+          (base32 "1znxavwsiy6czirjn0qi1p5yarnm7gg692nb0309hb6p4k4hpvbf"))))
+    (build-system python-build-system)
+    (propagated-inputs
+      `(("python-click" ,python-click)
+        ("python-click-default-group" ,python-click-default-group)
+        ("python-incremental" ,python-incremental)
+        ("python-jinja2" ,python-jinja2)
+        ("python-toml" ,python-toml)))
+    (native-inputs `(("python-packaging" ,python-packaging)))
+    (home-page "https://github.com/hawkowl/towncrier")
+    (synopsis "Tool to build newsfiles for your Python project")
+    (description "A utility to produce useful, summarised news files for your
+project. Rather than reading the Git history as some newer tools to produce it,
+or having one single file which developers all write to, towncrier reads
+\"news fragments\" which contain information useful to end users.")
+    (license license:expat)))