diff mbox series

[bug#50515,v3,1/2] website: Tweak 'GUIX_WEB_SITE_LOCAL'.

Message ID 20211021094138.2245-1-zimon.toutoune@gmail.com
State Accepted
Headers show
Series [bug#50515,v3,1/2] website: Tweak 'GUIX_WEB_SITE_LOCAL'. | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Simon Tournier Oct. 21, 2021, 9:41 a.m. UTC
* website/apps/packages/data.scm (%package-list): Compare to 'yes' instead of
any value.
* website/README: Document it.
---
 website/README                 | 8 ++++++++
 website/apps/packages/data.scm | 3 ++-
 2 files changed, 10 insertions(+), 1 deletion(-)


base-commit: 8b85fe7dd0bb000105f2bcd4955a7d2c6cd84298

Comments

Ludovic Courtès Oct. 21, 2021, 8:58 p.m. UTC | #1
zimoun <zimon.toutoune@gmail.com> skribis:

> * website/apps/packages/data.scm (%package-list): Compare to 'yes' instead of
> any value.
> * website/README: Document it.

[...]

> Using Guix 9875f9bca3976bf3576eab9be42164fde454597e, the packages considered
> by 'computed-origin-method' are IceCat and the Linux kernel; see:
> gnu/packages/gnuzilla.scm and gnu/packages/linux.scm.
>
> * website/apps/packages/builder.scm (gexp-references): Unexported procedure
> from the module '(guix gexp)'.
> (origin->json): Add 'computed-origin-method' case.
> (package-json-builder): Adjust.
> (sources-json-builder): Idem.

Finally pushed, thanks!

Ludo’.
diff mbox series

Patch

diff --git a/website/README b/website/README
index ce2819f..bc623c5 100644
--- a/website/README
+++ b/website/README
@@ -37,6 +37,14 @@  commands:
                           -- haunt build
 #+end_example
 
+Any other value than =GUIX_WEB_SITE_LOCAL=yes= will build the full website
+considering all the packages and not a small subset.  Note that the final
+website is built using the following command:
+
+#+begin_example
+  guix build -f .guix.scm
+#+end_example
+
 ** Serve locally
 #+begin_example
   LANG=en_US.UTF-8 guix environment -CN -m manifest.scm \
diff --git a/website/apps/packages/data.scm b/website/apps/packages/data.scm
index d1bbc92..eb34d26 100644
--- a/website/apps/packages/data.scm
+++ b/website/apps/packages/data.scm
@@ -50,7 +50,8 @@ 
                    (string<? (package-name p1)
                              (package-name p2))))))
       (cond ((null? packages) '())
-            ((getenv "GUIX_WEB_SITE_LOCAL") (list-head packages 300))
+            ((string=? "yes" (getenv "GUIX_WEB_SITE_LOCAL"))
+             (list-head packages 300))
             (else packages)))))
 
 (define (all-packages)