diff mbox series

[bug#51113] gnu: Add snooze.

Message ID 20211010075339.22230-1-jgart@dismail.de
State Accepted
Headers show
Series [bug#51113] gnu: Add snooze. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

jgart Oct. 10, 2021, 7:53 a.m. UTC
* gnu/packages/suckless.scm (snooze): New variable.
---
 gnu/packages/suckless.scm | 31 +++++++++++++++++++++++++++++++
 1 file changed, 31 insertions(+)

Comments

Nicolas Goaziou Oct. 13, 2021, 7:28 p.m. UTC | #1
Hello,

jgart via Guix-patches via <guix-patches@gnu.org> writes:

> * gnu/packages/suckless.scm (snooze): New variable.

Thank you. Some comments follow.

> +    (arguments
> +     `(#:tests? #f

Could you add a comment explaining why tests are disabled? I assume
upstream does not provide any.

> +       #:make-flags
> +       (list (string-append "CC=" ,(cc-for-target))
> +             (string-append "DESTDIR=" %output)
> +             "PREFIX=")

It may be worth explaining in a comment why PREFIX is reset.

> +       #:phases
> +       (modify-phases %standard-phases
> +         (delete 'configure))))
> +    (home-page "https://github.com/leahneukirchen/snooze")
> +    (synopsis "Run a command at a particular time")
> +    (description
> +"@command{snooze} is a new tool for waiting until a particular time and then
> +running a command.")

I would remove "new" from the description.

Otherwise, LGTM. Could you send an updated patch?

Regards,
jgart Oct. 19, 2021, 6:16 a.m. UTC | #2
On Wed, 13 Oct 2021 21:28:48 +0200 Nicolas Goaziou <mail@nicolasgoaziou.fr> wrote:
> Hello,
> 
> jgart via Guix-patches via <guix-patches@gnu.org> writes:
> 
> > * gnu/packages/suckless.scm (snooze): New variable.
> 
> Thank you. Some comments follow.
> 
> > +    (arguments
> > +     `(#:tests? #f
> 
> Could you add a comment explaining why tests are disabled? I assume
> upstream does not provide any.
> 
> > +       #:make-flags
> > +       (list (string-append "CC=" ,(cc-for-target))
> > +             (string-append "DESTDIR=" %output)
> > +             "PREFIX=")
> 
> It may be worth explaining in a comment why PREFIX is reset.
> 
> > +       #:phases
> > +       (modify-phases %standard-phases
> > +         (delete 'configure))))
> > +    (home-page "https://github.com/leahneukirchen/snooze")
> > +    (synopsis "Run a command at a particular time")
> > +    (description
> > +"@command{snooze} is a new tool for waiting until a particular time and then
> > +running a command.")
> 
> I would remove "new" from the description.
> 
> Otherwise, LGTM. Could you send an updated patch?

Hi Nicolas,

I forgot to CC you.

The updated patch is above. Thank you for taking the time to review the patch.

all best,

jgart
diff mbox series

Patch

diff --git a/gnu/packages/suckless.scm b/gnu/packages/suckless.scm
index b24eced379..1643c89990 100644
--- a/gnu/packages/suckless.scm
+++ b/gnu/packages/suckless.scm
@@ -873,6 +873,37 @@  It is a front end for ii-like chat programs.  It uses @code{tail -f} to get the
 chat output in the background.")
       (license license:isc))))
 
+(define-public snooze
+  (package
+    (name "snooze")
+    (version "0.5")
+    (source
+     (origin
+       (method git-fetch)
+       (uri
+        (git-reference
+         (url "https://github.com/leahneukirchen/snooze")
+         (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "02ng3r1gzgpyjia4b60i11dj5bhn3xjsdcbwmxaam6dzb33dmgib"))))
+    (build-system gnu-build-system)
+    (arguments
+     `(#:tests? #f
+       #:make-flags
+       (list (string-append "CC=" ,(cc-for-target))
+             (string-append "DESTDIR=" %output)
+             "PREFIX=")
+       #:phases
+       (modify-phases %standard-phases
+         (delete 'configure))))
+    (home-page "https://github.com/leahneukirchen/snooze")
+    (synopsis "Run a command at a particular time")
+    (description
+"@command{snooze} is a new tool for waiting until a particular time and then
+running a command.")
+    (license license:cc0)))
+
 (define-public scron
   (package
     (name "scron")