diff mbox series

[bug#51166] gnu: Add vim-surround

Message ID PU1PR01MB2155D93258CCA7B51E42F51E8DB69@PU1PR01MB2155.apcprd01.prod.exchangelabs.com
State Accepted
Headers show
Series [bug#51166] gnu: Add vim-surround | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Foo Chuan Wei Oct. 12, 2021, 4:46 p.m. UTC
* gnu/packages/vim.scm (vim-surround): New variable.
---
 gnu/packages/vim.scm | 26 ++++++++++++++++++++++++++
 1 file changed, 26 insertions(+)


base-commit: b9c7bbba38f4fb12d2735f2683a40c035f4e7f5f

Comments

Efraim Flashner Oct. 18, 2021, 12:49 p.m. UTC | #1
Thanks. Patch pushed.
diff mbox series

Patch

diff --git a/gnu/packages/vim.scm b/gnu/packages/vim.scm
index 92189b7094..415e9edb6d 100644
--- a/gnu/packages/vim.scm
+++ b/gnu/packages/vim.scm
@@ -1069,3 +1069,29 @@  your code every time you make a change.  @code{Vim-slime} is an attempt at
 getting some of these features into Vim.  It works with any REPL and isn't tied
 to Lisp.")
       (license license:expat))))
+
+(define-public vim-surround
+  (package
+    (name "vim-surround")
+    (version "2.2")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+              (url "https://github.com/tpope/vim-surround")
+              (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+         (base32 "1b0bd5m5lv1p4d299mrwjfs2gk0zqwyaqdaid9hs9yqlxnr8s5nf"))))
+    (build-system copy-build-system)
+    (arguments
+      '(#:install-plan
+        '(("doc" "share/vim/vimfiles/")
+          ("plugin" "share/vim/vimfiles/"))))
+    (home-page "https://github.com/tpope/vim-surround")
+    (synopsis "Vim plugin for easy quoting and parenthesizing")
+    (description
+      "Surround.vim is all about \"surroundings\": parentheses, brackets,
+quotes, XML tags, and more. The plugin provides mappings to easily delete,
+change and add such surroundings in pairs.")
+    (license license:vim)))