diff mbox series

[bug#51175] gnu: Add python-json2html.

Message ID 20211013045306.13449-1-jgart@dismail.de
State Accepted
Headers show
Series [bug#51175] gnu: Add python-json2html. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

jgart Oct. 13, 2021, 4:53 a.m. UTC
* gnu/packages/python-xyz.scm (python-json2html): New variable.
---
 gnu/packages/python-xyz.scm | 29 +++++++++++++++++++++++++++++
 1 file changed, 29 insertions(+)

Comments

Arun Isaac Oct. 16, 2021, 11:27 a.m. UTC | #1
Hi jgart,

Thanks for the patch! I have pushed to master with a few minor
improvements to the synopsis and description.

Thanks,
Arun
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index dc0f12ed91..1cb4f37fe5 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -27197,6 +27197,35 @@  location.  This small Python module determines the appropriate
 platform-specific directories, e.g. the ``user data dir''.")
     (license license:expat)))
 
+(define-public python-json2html
+  (package
+    (name "python-json2html")
+    (version "1.3.0")
+    (source ; There are no tests in the PyPI tarball.
+     (origin 
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/softvar/json2html")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "1ncypljnl5y8lsxy6ibcqy412kx3mzxl4ajg67568hvq98kv1sb3"))))
+    (build-system python-build-system)
+    (arguments
+     '(#:phases
+       (modify-phases %standard-phases
+         (replace 'check
+           (lambda* (#:key tests? inputs outputs #:allow-other-keys)
+             (when tests?
+               (add-installed-pythonpath inputs outputs)
+               (invoke "python" "test/run_tests.py")))))))
+    (home-page "https://github.com/softvar/json2html")
+    (synopsis "JSON to HTML Table Representation")
+    (description 
+"Python module to convert JSON into a human readable HTML Table
+ representation.")
+    (license license:expat)))
+
 (define-public python-face
   (package
     (name "python-face")