diff mbox

[bug#50793,0/2] cloudflare-cli and dependency JSON.sh

Message ID 87czo9s3b4.fsf_-_@gnu.org
State Accepted
Headers show

Commit Message

Ludovic Courtès Oct. 13, 2021, 9:05 a.m. UTC
Hi,

Stephen Paul Weber <singpolyma@singpolyma.net> skribis:

> * gnu/packages/serialization.scm (JSON.sh): New variable.

Applied with the cosmetic changes below.

Thanks,
Ludo’.

Comments

Maxim Cournoyer Oct. 13, 2021, 7:03 p.m. UTC | #1
Hello!

Ludovic Courtès <ludo@gnu.org> writes:

> Hi,
>
> Stephen Paul Weber <singpolyma@singpolyma.net> skribis:
>
>> * gnu/packages/serialization.scm (JSON.sh): New variable.
>
> Applied with the cosmetic changes below.

Didn't we have some coding style preferring hyphens over '.' ?  I can't
find any of this in our manual, but ISTR that there were some commits
made to adjust package names that had '.' in them.

Thanks!
Simon Tournier Oct. 14, 2021, 8:54 a.m. UTC | #2
Hi,

On Wed, 13 Oct 2021 at 15:03, Maxim Cournoyer <maxim.cournoyer@gmail.com> wrote:

> Didn't we have some coding style preferring hyphens over '.' ?  I can't
> find any of this in our manual, but ISTR that there were some commits
> made to adjust package names that had '.' in them.

Yes, the implicit rule of thumb is to prefer hyphens ’-’ over dot ’.’
for naming variable.  Indeed, I do not find neither this in manual.

Is it better to add a lint checker?  Or just add an item to

<https://guix.gnu.org/manual/devel/en/guix.html#Submitting-Patches>

?

Cheers,
simon
Maxim Cournoyer Oct. 15, 2021, 3:26 a.m. UTC | #3
Hello Simon,

zimoun <zimon.toutoune@gmail.com> writes:

> Hi,
>
> On Wed, 13 Oct 2021 at 15:03, Maxim Cournoyer <maxim.cournoyer@gmail.com> wrote:
>
>> Didn't we have some coding style preferring hyphens over '.' ?  I can't
>> find any of this in our manual, but ISTR that there were some commits
>> made to adjust package names that had '.' in them.
>
> Yes, the implicit rule of thumb is to prefer hyphens ’-’ over dot ’.’
> for naming variable.  Indeed, I do not find neither this in manual.
>
> Is it better to add a lint checker?  Or just add an item to
>
> <https://guix.gnu.org/manual/devel/en/guix.html#Submitting-Patches>

I'd say both!  Were you volunteering to add it? :-)

Thanks,

Maxim
Ludovic Courtès Oct. 15, 2021, 3:28 p.m. UTC | #4
Hi,

Maxim Cournoyer <maxim.cournoyer@gmail.com> skribis:

> Ludovic Courtès <ludo@gnu.org> writes:
>
>> Hi,
>>
>> Stephen Paul Weber <singpolyma@singpolyma.net> skribis:
>>
>>> * gnu/packages/serialization.scm (JSON.sh): New variable.
>>
>> Applied with the cosmetic changes below.
>
> Didn't we have some coding style preferring hyphens over '.' ?  I can't
> find any of this in our manual, but ISTR that there were some commits
> made to adjust package names that had '.' in them.

Ah, I wasn’t sure, but I can change it to a hyphen.

Thanks!

Ludo’.
diff mbox

Patch

diff --git a/gnu/packages/serialization.scm b/gnu/packages/serialization.scm
index 07ce5f2537..e24ef973b5 100644
--- a/gnu/packages/serialization.scm
+++ b/gnu/packages/serialization.scm
@@ -462,7 +462,7 @@  (define-public jsoncpp-for-tensorflow
                 "1180ln8blrb0mwzpcf78k49hlki6di65q77rsvglf83kfcyh4d7z"))))))
 
 (define-public json.sh
-  (let ((commit "0d5e5c77365f63809bf6e77ef44a1f34b0e05840")
+  (let ((commit "0d5e5c77365f63809bf6e77ef44a1f34b0e05840") ;no releases
         (revision "1"))
     (package
       (name "json.sh")
@@ -499,14 +499,14 @@  (define-public json.sh
        `(("bash-minimal" ,bash-minimal)
          ("grep" ,grep)
          ("sed" ,sed)))
-      (synopsis
-        "Pipeable JSON parser written in shell")
+      (synopsis "Pipeable JSON parser written in shell")
       (description
-        "A JSON parser written in shell, compatible with ash, bash, dash and zsh.
-Pipe json to it, and it traverses the json objects and prints out the path to
-the current object (as a JSON array) and then the object, without whitespace.")
+        "This package provides a JSON parser written in shell, compatible with
+ash, Bash, Dash and Zsh.  Pipe JSON to it, and it traverses the JSON objects
+and prints out the path to the current object (as a JSON array) and then the
+object, without whitespace.")
       (home-page "https://github.com/dominictarr/JSON.sh")
-      (license (list license:expat license:asl2.0)))))
+      (license (list license:expat license:asl2.0))))) ;dual-licensed
 
 (define-public capnproto
   (package