diff mbox series

[bug#51126] gnu: kdenlive: Update to 21.08.2.

Message ID 20211011000446.409456-1-monego@posteo.net
State Accepted
Headers show
Series [bug#51126] gnu: kdenlive: Update to 21.08.2. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Vinicius Monego Oct. 11, 2021, 12:04 a.m. UTC
* gnu/packages/kde.scm (kdenlive): Update to 21.08.2.
---
 gnu/packages/kde.scm | 9 ++++++---
 1 file changed, 6 insertions(+), 3 deletions(-)

Comments

Leo Famulari Oct. 12, 2021, 3:15 p.m. UTC | #1
On Mon, Oct 11, 2021 at 12:04:46AM +0000, Vinicius Monego wrote:
> * gnu/packages/kde.scm (kdenlive): Update to 21.08.2.

Pushed as 385c9a4e30e952207df3246acaf13e6519b01af2

>        (arguments
> -       `(#:tests? #f                    ;TODO needs X
> +       ;; XXX: there is a single test that spawns other tests and
> +       ;; 1/3 tests failed and 1/327 assertions failed.  It seems
> +       ;; that individual tests can't be skipped.
> +       `(#:tests? #f

Thank you for taking the time to investigate and write this comment.
It's important work for the long-term maintainability of the packages.
diff mbox series

Patch

diff --git a/gnu/packages/kde.scm b/gnu/packages/kde.scm
index 66a112d8b5..93ffa0f43a 100644
--- a/gnu/packages/kde.scm
+++ b/gnu/packages/kde.scm
@@ -219,7 +219,7 @@  browser for easy news reading.")
     (license license:gpl2+)))
 
 (define-public kdenlive
-  (let ((version "21.08.1"))
+  (let ((version "21.08.2"))
     (package
       (name "kdenlive")
       (version version)
@@ -231,7 +231,7 @@  browser for easy news reading.")
                (commit (string-append "v" version))))
          (file-name (string-append name "-" version "-checkout"))
          (sha256
-          (base32 "1fvy2aa86pn4crk8lgxjh1kdn2lxzi66krnrr9m91mp89mmc760k"))))
+          (base32 "1l78xjdf1bmj3s8kysaqqgh67mb3vrc96rsdnp0i4awlyfsh89d7"))))
       (build-system qt-build-system)
       (native-inputs
        `(("extra-cmake-modules" ,extra-cmake-modules)
@@ -269,7 +269,10 @@  browser for easy news reading.")
          ("qtwebkit" ,qtwebkit)
          ("shared-mime-info" ,shared-mime-info)))
       (arguments
-       `(#:tests? #f                    ;TODO needs X
+       ;; XXX: there is a single test that spawns other tests and
+       ;; 1/3 tests failed and 1/327 assertions failed.  It seems
+       ;; that individual tests can't be skipped.
+       `(#:tests? #f
          #:phases
          (modify-phases %standard-phases
            (add-after 'install 'wrap-executable