diff mbox series

[bug#49469] gnu: Add python-pysox.

Message ID 20210708193555.4907-1-jgart@dismail.de
State Accepted
Headers show
Series [bug#49469] gnu: Add python-pysox. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

jgart July 8, 2021, 7:35 p.m. UTC
* gnu/packages/audio.scm (python-pysox): New variable.
---
 gnu/packages/audio.scm | 30 ++++++++++++++++++++++++++++++
 1 file changed, 30 insertions(+)

Comments

Arun Isaac Oct. 9, 2021, 3:20 p.m. UTC | #1
Hi jgart,

> +     ;; Tests require python-soundfile.
> +     ;; TODO: enable tests once http://issues.guix.gnu.org/47181 is completed.
> +     `(#:tests? #f))

python-soundfile is now in Guix. Could you try getting the tests
working?

Thank you!
Arun
diff mbox series

Patch

diff --git a/gnu/packages/audio.scm b/gnu/packages/audio.scm
index 3939d4bc7e..5222fb0343 100644
--- a/gnu/packages/audio.scm
+++ b/gnu/packages/audio.scm
@@ -2385,6 +2385,36 @@  compensation, (de)interleaving, and byte-swapping
     ;; original developer.
     (license license:expat)))
 
+(define-public python-pysox
+  (package
+    (name "python-pysox")
+    (version "1.4.1")
+    (source
+      (origin
+        (method url-fetch)
+        (uri (pypi-uri "sox" version))
+        (sha256
+          (base32
+            "0m8hszh51lfzacbb4nxc5bn446c0dzljfqgnsff8h2s5j8vd3wmh"))))
+    (build-system python-build-system)
+    (arguments
+     ;; Tests require python-soundfile.
+     ;; TODO: enable tests once http://issues.guix.gnu.org/47181 is completed.
+     `(#:tests? #f))
+    (propagated-inputs
+      `(("python-numpy" ,python-numpy)))
+    (native-inputs
+      `(("python-pytest" ,python-pytest)
+        ("python-pytest-cov" ,python-pytest-cov)))
+    (home-page "https://github.com/rabitt/pysox")
+    (synopsis "Python wrapper around sox")
+    (description "@code{pysox} is a wrapper around the @command{sox} command line tool.
+ pysox's API offers @code{Transformer} and @code{Combiner} classes that allow the user to
+incrementally build up effects and audio manipulations.  @code{pysox} also
+provides methods for querying audio information such as sample rate,
+determining whether an audio file is silent and much more.")
+    (license license:bsd-3)))
+
 (define-public python-pyaudio
   (package
     (name "python-pyaudio")