diff mbox series

[bug#49451,06/20] gnu: rust-fragile: Update to 1.0

Message ID YOtiqtuKcgtiFFMu@thunix.net
State New
Headers show
Series [bug#49451,01/20] gnu: rust-blake2: Update to 0.9 | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

southerntofu July 11, 2021, 9:29 p.m. UTC
---
 gnu/packages/crates-io.scm | 23 +++++++++++++++++++++++
 1 file changed, 23 insertions(+)

Comments

Xinglu Chen Aug. 1, 2021, 10:13 a.m. UTC | #1
On Sun, Jul 11 2021, southerntofu via Guix-patches via wrote:

> ---
>  gnu/packages/crates-io.scm | 23 +++++++++++++++++++++++
>  1 file changed, 23 insertions(+)
>
> diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
> index e322661709..258649f6a0 100644
> --- a/gnu/packages/crates-io.scm
> +++ b/gnu/packages/crates-io.scm
> @@ -16452,6 +16452,29 @@ implementation that is more efficient for smaller hash keys.")
>  syntax, as used by HTML forms.")
>      (license (list license:expat license:asl2.0))))
>  
> +(define-public rust-fragile-1
> +  (package
> +    (name "rust-fragile")
> +    (version "1.0.0")
> +    (source
> +      (origin
> +        (method url-fetch)
> +        (uri (crate-uri "fragile" version))
> +        (file-name
> +          (string-append name "-" version ".tar.gz"))
> +        (sha256
> +          (base32
> +            "1wlihmkjyhvl5rckal32p010piy1l15s6l81h7z31jcd971kk839"))))
> +    (build-system cargo-build-system)
> +    (arguments `(#:skip-build? #t))
> +    (home-page
> +      "https://github.com/mitsuhiko/rust-fragile")
> +    (synopsis
> +      "Provides wrapper types for sending non-send values to other threads")
> +    (description
> +      "Provides wrapper types for sending non-send values to other threads")

Full sentence and missing period.
diff mbox series

Patch

diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index e322661709..258649f6a0 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -16452,6 +16452,29 @@  implementation that is more efficient for smaller hash keys.")
 syntax, as used by HTML forms.")
     (license (list license:expat license:asl2.0))))
 
+(define-public rust-fragile-1
+  (package
+    (name "rust-fragile")
+    (version "1.0.0")
+    (source
+      (origin
+        (method url-fetch)
+        (uri (crate-uri "fragile" version))
+        (file-name
+          (string-append name "-" version ".tar.gz"))
+        (sha256
+          (base32
+            "1wlihmkjyhvl5rckal32p010piy1l15s6l81h7z31jcd971kk839"))))
+    (build-system cargo-build-system)
+    (arguments `(#:skip-build? #t))
+    (home-page
+      "https://github.com/mitsuhiko/rust-fragile")
+    (synopsis
+      "Provides wrapper types for sending non-send values to other threads")
+    (description
+      "Provides wrapper types for sending non-send values to other threads")
+    (license license:asl2.0)))
+
 (define-public rust-fragile-0.3
   (package
     (name "rust-fragile")