diff mbox series

[bug#49451,01/20] gnu: rust-blake2: Update to 0.9

Message ID YOtiBSriYMVZ5WYS@thunix.net
State New
Headers show
Series [bug#49451,01/20] gnu: rust-blake2: Update to 0.9 | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

southerntofu July 11, 2021, 9:26 p.m. UTC
---
 gnu/packages/crates-io.scm | 27 +++++++++++++++++++++++++++
 1 file changed, 27 insertions(+)

Comments

Xinglu Chen Aug. 1, 2021, 10:08 a.m. UTC | #1
On Sun, Jul 11 2021, southerntofu via Guix-patches via wrote:

> ---

Please write commit messages in the GNU ChangeLog format; you can look
at the commit log for examples, or see the manual.

  <https://www.gnu.org/prep/standards/html_node/Change-Logs.html>

If you use emacs, you can use the Yasnippet snippets found in the
etc/snippets/text-mode directory when writing commit messages.

>  gnu/packages/crates-io.scm | 27 +++++++++++++++++++++++++++
>  1 file changed, 27 insertions(+)
>
> diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
> index d53f8fb525..5ed2ff470e 100644
> --- a/gnu/packages/crates-io.scm
> +++ b/gnu/packages/crates-io.scm
> @@ -5207,6 +5207,33 @@ streams in big-endian and little-endian formats.")
>       "This package provides a crate for manipulating memory, bit by bit.")
>      (license license:expat)))
>  
> +(define-public rust-blake2-0.9
> +  (package
> +    (name "rust-blake2")
> +    (version "0.9.1")
> +    (source
> +      (origin
> +        (method url-fetch)
> +        (uri (crate-uri "blake2" version))
> +        (file-name
> +          (string-append name "-" version ".tar.gz"))
> +        (sha256
> +          (base32
> +            "1x3qz692hfrxgw6cd94iiid6iqal2dwj6zv5137swpgg4l17598h"))))
> +    (build-system cargo-build-system)
> +    (arguments
> +      `(#:skip-build?
> +        #t
> +        #:cargo-inputs
> +        (("rust-crypto-mac" ,rust-crypto-mac-0.8)
> +         ("rust-digest" ,rust-digest-0.9)
> +         ("rust-opaque-debug" ,rust-opaque-debug-0.3))))
> +    (home-page
> +      "https://github.com/RustCrypto/hashes")
> +    (synopsis "BLAKE2 hash functions")
> +    (description "BLAKE2 hash functions")

The description should consist of one ore more full sentences, see
“16.4.4 Synopses and Descriptions” in the manual.

Make sure to run ‘guix lint’ to avoid common mistakes like these.

Also, I noticed that a ‘rust-blake2-0.8’ package already exists, maybe
it would be possible to update that to 0.9, or make it inherit from
‘rust-blake2-0.9’ to avoid some code duplication.
diff mbox series

Patch

diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index d53f8fb525..5ed2ff470e 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -5207,6 +5207,33 @@  streams in big-endian and little-endian formats.")
      "This package provides a crate for manipulating memory, bit by bit.")
     (license license:expat)))
 
+(define-public rust-blake2-0.9
+  (package
+    (name "rust-blake2")
+    (version "0.9.1")
+    (source
+      (origin
+        (method url-fetch)
+        (uri (crate-uri "blake2" version))
+        (file-name
+          (string-append name "-" version ".tar.gz"))
+        (sha256
+          (base32
+            "1x3qz692hfrxgw6cd94iiid6iqal2dwj6zv5137swpgg4l17598h"))))
+    (build-system cargo-build-system)
+    (arguments
+      `(#:skip-build?
+        #t
+        #:cargo-inputs
+        (("rust-crypto-mac" ,rust-crypto-mac-0.8)
+         ("rust-digest" ,rust-digest-0.9)
+         ("rust-opaque-debug" ,rust-opaque-debug-0.3))))
+    (home-page
+      "https://github.com/RustCrypto/hashes")
+    (synopsis "BLAKE2 hash functions")
+    (description "BLAKE2 hash functions")
+    (license (list license:expat license:asl2.0))))
+
 (define-public rust-blake2-0.8
   (package
     (name "rust-blake2")