diff mbox series

[bug#49520] Minor fixes to interception-tools and update dual-function-keys.

Message ID NEIrg3jAQLk3rSccOnD0bUTFfuykBE5q-8fJunGFpO6gVZvgUk83mlAv9XWqbcG2n1XPQvGFVAI230sGJNNou14ZiV1XHoHz9aN_a9WO7R4=@apatience.com
State Accepted
Headers show
Series [bug#49520] Minor fixes to interception-tools and update dual-function-keys. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Paul A. Patience July 11, 2021, 4:31 a.m. UTC
Empty Message

Comments

Ludovic Courtès July 26, 2021, 5:36 p.m. UTC | #1
Hi,

"Paul A. Patience" <paul@apatience.com> skribis:

> From 34e0d095c51cb37a10b338586446c48eec9c7bca Mon Sep 17 00:00:00 2001
> From: "Paul A. Patience" <paul@apatience.com>
> Date: Sun, 11 Jul 2021 00:08:39 -0400
> Subject: [PATCH 1/3] gnu: interception-tools: Make minor fixes.
>
> * gnu/packages/linux.scm (interception-tools)[inputs]: Move boost to...
> [native-inputs]: ...here. New field.
> [license]: gpl3+ -> gpl3.


[...]

> +    (native-inputs
> +     `(("boost" ,boost)))
>      (inputs
> -     `(("boost" ,boost)
> -       ("libevdev" ,libevdev)
> +     `(("libevdev" ,libevdev)

I believe Boost should remain in ‘inputs’ or it would not be found when
cross-compiling.

> -    ;; Dual-licensed under GPLv3+ or "something else" on request, per
> +    ;; Dual-licensed under GPLv3 or "something else" on request, per
>      ;; 'README.md'.
> -    (license license:gpl3+)))
> +    (license license:gpl3)))

AFAICS, nothing in the source says “version 3 only”, so ‘gpl3+’ is correct.

It seems to me this patch can be dropped.  WDYT?

> From c324fef966098f885454f5afb0687db137d4c7d0 Mon Sep 17 00:00:00 2001
> From: "Paul A. Patience" <paul@apatience.com>
> Date: Sun, 11 Jul 2021 00:22:46 -0400
> Subject: [PATCH 3/3] gnu: interception-dual-function-keys: Update to 1.4.0.
> 
> * gnu/packages/linux.scm (interception-dual-function-keys)
> [version]: Update to 1.4.0.

Applied.

> From 83c06ca8d7b52c7dc7c38ed2c476ff39047f5cd2 Mon Sep 17 00:00:00 2001
> From: "Paul A. Patience" <paul@apatience.com>
> Date: Sun, 11 Jul 2021 00:19:56 -0400
> Subject: [PATCH 2/3] gnu: interception-dual-function-keys: Minor fixes.
>
> * gnu/packages/linux.scm (interception-dual-function-keys)
> [arguments]<#:make-flags>: Make use of cc-for-target, cxx-for-target and
> %output.
> <#:phases>{check}: Undelete phase. Disable tests instead with...
> <#:tests?>: ...this. New field.

Applied, thanks!

Ludo’.
M July 26, 2021, 6:06 p.m. UTC | #2
Ludovic Courtès schreef op ma 26-07-2021 om 19:36 [+0200]:
> Hi,
> 
> "Paul A. Patience" <paul@apatience.com> skribis:
> 
> > From 34e0d095c51cb37a10b338586446c48eec9c7bca Mon Sep 17 00:00:00 2001
> > From: "Paul A. Patience" <paul@apatience.com>
> > Date: Sun, 11 Jul 2021 00:08:39 -0400
> > Subject: [PATCH 1/3] gnu: interception-tools: Make minor fixes.
> > 
> > * gnu/packages/linux.scm (interception-tools)[inputs]: Move boost to...
> > [native-inputs]: ...here. New field.
> > [license]: gpl3+ -> gpl3.
> 
> [...]
> 
> > +    (native-inputs
> > +     `(("boost" ,boost)))
> >      (inputs
> > -     `(("boost" ,boost)
> > -       ("libevdev" ,libevdev)
> > +     `(("libevdev" ,libevdev)
> 
> I believe Boost should remain in ‘inputs’ or it would not be found when
> cross-compiling.
> 
> > -    ;; Dual-licensed under GPLv3+ or "something else" on request, per
> > +    ;; Dual-licensed under GPLv3 or "something else" on request, per
> >      ;; 'README.md'.
> > -    (license license:gpl3+)))
> > +    (license license:gpl3)))
> 
> AFAICS, nothing in the source says “version 3 only”, so ‘gpl3+’ is correct.

Nothing in the source mentions any version number (aside the license text 
itself), so gpl1+ is correct according to section ‘14. Revised Versions of this License’:

  [...].  If the Program does not specify a version number of the
GNU General Public License, you may choose any version ever published
by the Free Software Foundation.

This is probably not the intention of the author though,
so maybe write license:gpl3+ anyway, and ‘someone’ should submit a bug report or patch
upstream.

-- Actually, a version number is specified somewhere.  In the README
(https://gitlab.com/interception/linux/tools#license) there is a ‘GPLv3 Free Software’
icon. So GPLv1 and GPLv2 are out.  I'm not sure if GPLv4, GPLv5 ... are allowed
in this case.

Greetings,
Maxime.
Paul A. Patience July 26, 2021, 11:58 p.m. UTC | #3
On Monday, July 26th, 2021 at 13:36, Ludovic Courtès <ludo@gnu.org> wrote:
> "Paul A. Patience" <paul@apatience.com> skribis:
>
>> From 34e0d095c51cb37a10b338586446c48eec9c7bca Mon Sep 17 00:00:00 2001
>> From: "Paul A. Patience" <paul@apatience.com>
>> Date: Sun, 11 Jul 2021 00:08:39 -0400
>> Subject: [PATCH 1/3] gnu: interception-tools: Make minor fixes.
>>
>> * gnu/packages/linux.scm (interception-tools)[inputs]: Move boost to...
>> [native-inputs]: ...here. New field.
>> [license]: gpl3+ -> gpl3.

<snip>

> It seems to me this patch can be dropped.  WDYT?

Sounds good.

Thanks,
Paul
Ludovic Courtès July 27, 2021, 10:05 a.m. UTC | #4
Hi Maxime,

Maxime Devos <maximedevos@telenet.be> skribis:

> Ludovic Courtès schreef op ma 26-07-2021 om 19:36 [+0200]:

[...]

>> > -    ;; Dual-licensed under GPLv3+ or "something else" on request, per
>> > +    ;; Dual-licensed under GPLv3 or "something else" on request, per
>> >      ;; 'README.md'.
>> > -    (license license:gpl3+)))
>> > +    (license license:gpl3)))
>> 
>> AFAICS, nothing in the source says “version 3 only”, so ‘gpl3+’ is correct.
>
> Nothing in the source mentions any version number (aside the license text 
> itself), so gpl1+ is correct according to section ‘14. Revised Versions of this License’:
>
>   [...].  If the Program does not specify a version number of the
> GNU General Public License, you may choose any version ever published
> by the Free Software Foundation.

I agree, though the way we encode it in Guix is ‘gpl3+’.

> -- Actually, a version number is specified somewhere.  In the README
> (https://gitlab.com/interception/linux/tools#license) there is a ‘GPLv3 Free Software’
> icon. So GPLv1 and GPLv2 are out.  I'm not sure if GPLv4, GPLv5 ... are allowed
> in this case.

My interpretation is that it’s “version 3 or later”.

Thanks,
Ludo’.
diff mbox series

Patch

From 83c06ca8d7b52c7dc7c38ed2c476ff39047f5cd2 Mon Sep 17 00:00:00 2001
From: "Paul A. Patience" <paul@apatience.com>
Date: Sun, 11 Jul 2021 00:19:56 -0400
Subject: [PATCH 2/3] gnu: interception-dual-function-keys: Minor fixes.

* gnu/packages/linux.scm (interception-dual-function-keys)
[arguments]<#:make-flags>: Make use of cc-for-target, cxx-for-target and
%output.
<#:phases>{check}: Undelete phase. Disable tests instead with...
<#:tests?>: ...this. New field.
---
 gnu/packages/linux.scm | 11 ++++++-----
 1 file changed, 6 insertions(+), 5 deletions(-)

diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 817df615b1..8fa723bc1a 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -3738,8 +3738,9 @@  devices that can inject events directly into the input subsystem.")
      `(("libevdev" ,libevdev)
        ("yaml-cpp" ,yaml-cpp)))
     (arguments
-     `(#:make-flags (list "CC=gcc" "CXX=g++"
-                          (string-append "PREFIX=" (assoc-ref %outputs "out")))
+     `(#:make-flags (list ,(string-append "CC=" (cc-for-target))
+                          ,(string-append "CXX=" (cxx-for-target))
+                          (string-append "PREFIX=" %output))
        #:phases
        (modify-phases %standard-phases
          (add-after 'unpack 'fix-libevdev-path
@@ -3750,9 +3751,9 @@  devices that can inject events directly into the input subsystem.")
                   (string-append libevdev "/include/libevdev-1.0")))
                #t)))
          ;; No configure script
-         (delete 'configure)
-         ;; No target 'check'
-         (delete 'check))))
+         (delete 'configure))
+       ;; No tests are included.
+       #:tests? #f))
     (synopsis "Tap for one key, hold for another")
     (description
      "Dual Function Keys is a plugin for @code{interception-tools} that allows
-- 
2.32.0