diff mbox series

[bug#49539,v2] gnu: Add nginx-rtmp-module.

Message ID 20210712211322.14238-1-jackhill@jackhill.us
State Accepted
Headers show
Series [bug#49539,v2] gnu: Add nginx-rtmp-module. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Jack Hill July 12, 2021, 9:13 p.m. UTC
* gnu/packages/web.scm (nginx-rtmp-module): New variable.
---
 gnu/packages/web.scm | 61 ++++++++++++++++++++++++++++++++++++++++++++
 1 file changed, 61 insertions(+)

Comments

Sarah Morgensen July 22, 2021, 4:05 a.m. UTC | #1
Hi!

Jack Hill <jackhill@jackhill.us> writes:

> * gnu/packages/web.scm (nginx-rtmp-module): New variable.
> ---
>  gnu/packages/web.scm | 61 ++++++++++++++++++++++++++++++++++++++++++++
>  1 file changed, 61 insertions(+)
>
> diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
> index 2cc8619b19..a659ad456a 100644
> --- a/gnu/packages/web.scm
> +++ b/gnu/packages/web.scm
> @@ -50,6 +50,7 @@
>  ;;; Copyright © 2021 Stefan Reichör <stefan@xsteve.at>
>  ;;; Copyright © 2021 la snesne <lasnesne@lagunposprasihopre.org>
>  ;;; Copyright © 2021 Matthew James Kraai <kraai@ftbfs.org>
> +;;; Copyright © 2021 Jack Hill <jackhill@jackhill.us>
>  ;;;
>  ;;; This file is part of GNU Guix.
>  ;;;
> @@ -771,6 +772,66 @@ documentation.")
>      (description "This NGINX module provides a scripting support with Lua
>  programming language.")))
>  
> +(define-public nginx-rtmp-module
> +  (package
> +    (inherit nginx)
> +    (name "nginx-rtmp-module")
> +    (version "1.2.2")
> +    (source
> +     (origin
> +       (method git-fetch)
> +       (uri (git-reference
> +             (url "https://github.com/arut/nginx-rtmp-module")
> +             (commit (string-append "v" version))))
> +       (file-name (git-file-name name version))
> +       (sha256
> +        (base32 "0y45bswk213yhkc2v1xca2rnsxrhx8v6azxz9pvi71vvxcggqv6h"))))
> +    (build-system gnu-build-system)
> +    (inputs
> +     `(("nginx-sources" ,(package-source nginx))
> +       ,@(package-inputs nginx)))
> +    (arguments
> +     (substitute-keyword-arguments
> +         `(#:configure-flags '("--add-dynamic-module=.")
> +           #:make-flags '("modules")
> +           #:modules ((guix build utils)
> +                      (guix build gnu-build-system))
> +           ,@(package-arguments nginx))
> +       ((#:phases phases)
> +        `(modify-phases ,phases
> +           ;; The LICENSE file will be overwritten with the one from nginx
> +           ;; when unpacking the nginx source, so copy this one to its own
> +           ;; file.
> +           (add-after 'unpack 'preserve-license-file
> +             (lambda _ (copy-file "LICENSE" "LICENSE.rtmp")))
> +           (add-after 'preserve-license-file 'unpack-nginx-sources
> +             (lambda* (#:key inputs native-inputs #:allow-other-keys)
> +               (begin
> +                 ;; The nginx source code is part of the module’s source.
> +                 (format #t "decompressing nginx source code~%")
> +                 (let ((tar (assoc-ref inputs "tar"))
> +                       (nginx-srcs (assoc-ref inputs "nginx-sources")))
> +                   (invoke (string-append tar "/bin/tar")
> +                           "xvf" nginx-srcs "--strip-components=1"))

You can probably drop the direct reference to tar and just use `(invoke
"tar" ...)`

Also, if you want to avoid the extra step of renaming the original
LICENSE, you can use `--transform=s,/LICENSE$,/LICENSE.nginx,` as an
argument to tar.

> +                 #t)))
> +           (replace 'install
> +             (lambda* (#:key outputs #:allow-other-keys)
> +               (let ((modules-dir (string-append (assoc-ref outputs "out")
> +                                                 "/etc/nginx/modules")))
> +                 (install-file "objs/ngx_rtmp_module.so" modules-dir)
> +                 #t)))
> +           (delete 'fix-root-dirs)
> +           (delete 'install-man-page)))))
> +    (home-page "https://github.com/arut/nginx-rtmp-module")
> +    (synopsis "NGINX module for audio and video streaming with RTMP")
> +    (description "This NGINX module provides streaming with the @acronym{RTMP,
> +Real-Time Messaging Protocol}, @acronym{DASH, Dynamic Adaptive Streaming over HTTP},
> +and @acronym{HLS, HTTP Live Streaming} protocols.  It allows NGINX to accept
> +incoming RTMP streams for recording or redistribution.  It also supports
> +on-demand streaming from a file on disk and pulling from an upstream RTMP
> +stream.  Remote control of the module is possible over HTTP.")
> +    (license license:bsd-2)))
> +
>  (define-public lighttpd
>    (package
>      (name "lighttpd")

--
Sarah
Jack Hill July 22, 2021, 8:53 p.m. UTC | #2
On Wed, 21 Jul 2021, Sarah Morgensen wrote:

> Jack Hill <jackhill@jackhill.us> writes:
>
>> +       ((#:phases phases)
>> +        `(modify-phases ,phases
>> +           ;; The LICENSE file will be overwritten with the one from nginx
>> +           ;; when unpacking the nginx source, so copy this one to its own
>> +           ;; file.
>> +           (add-after 'unpack 'preserve-license-file
>> +             (lambda _ (copy-file "LICENSE" "LICENSE.rtmp")))
>> +           (add-after 'preserve-license-file 'unpack-nginx-sources
>> +             (lambda* (#:key inputs native-inputs #:allow-other-keys)
>> +               (begin
>> +                 ;; The nginx source code is part of the module’s source.
>> +                 (format #t "decompressing nginx source code~%")
>> +                 (let ((tar (assoc-ref inputs "tar"))
>> +                       (nginx-srcs (assoc-ref inputs "nginx-sources")))
>> +                   (invoke (string-append tar "/bin/tar")
>> +                           "xvf" nginx-srcs "--strip-components=1"))
>
> You can probably drop the direct reference to tar and just use `(invoke
> "tar" ...)`
>
> Also, if you want to avoid the extra step of renaming the original
> LICENSE, you can use `--transform=s,/LICENSE$,/LICENSE.nginx,` as an
> argument to tar.

Thanks for suggesting these improvements! I've incorporated them into a 
version 3 that I'll post shortly.

Best,
Jack

P.S. The same opportunities for improvement exists in some of our other 
nginx modules, from which I copied this phase. The next time we update 
those might be a good time to clean them up.
Sarah Morgensen July 24, 2021, 10:07 p.m. UTC | #3
Hi,

Glad I could help. I forgot to mention also, the `begin` probably isn't
necessary (it's probably leftover from when it was a snippet somewhere),
but as you say that can be taken care of over time.

Jack Hill <jackhill@jackhill.us> writes:

[...]

> P.S. The same opportunities for improvement exists in some of our other nginx
> modules, from which I copied this phase. The next time we update those might be
> a good time to clean them up.

How common is this? Would it warrant an nginx-build-system, or perhaps
even a common idiom/general system for packages using multiple sources?
Or are the ways in which these packages uses secondary sources different
enough that unifying them would be difficult?

--
Sarah
diff mbox series

Patch

diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index 2cc8619b19..a659ad456a 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -50,6 +50,7 @@ 
 ;;; Copyright © 2021 Stefan Reichör <stefan@xsteve.at>
 ;;; Copyright © 2021 la snesne <lasnesne@lagunposprasihopre.org>
 ;;; Copyright © 2021 Matthew James Kraai <kraai@ftbfs.org>
+;;; Copyright © 2021 Jack Hill <jackhill@jackhill.us>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -771,6 +772,66 @@  documentation.")
     (description "This NGINX module provides a scripting support with Lua
 programming language.")))
 
+(define-public nginx-rtmp-module
+  (package
+    (inherit nginx)
+    (name "nginx-rtmp-module")
+    (version "1.2.2")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/arut/nginx-rtmp-module")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "0y45bswk213yhkc2v1xca2rnsxrhx8v6azxz9pvi71vvxcggqv6h"))))
+    (build-system gnu-build-system)
+    (inputs
+     `(("nginx-sources" ,(package-source nginx))
+       ,@(package-inputs nginx)))
+    (arguments
+     (substitute-keyword-arguments
+         `(#:configure-flags '("--add-dynamic-module=.")
+           #:make-flags '("modules")
+           #:modules ((guix build utils)
+                      (guix build gnu-build-system))
+           ,@(package-arguments nginx))
+       ((#:phases phases)
+        `(modify-phases ,phases
+           ;; The LICENSE file will be overwritten with the one from nginx
+           ;; when unpacking the nginx source, so copy this one to its own
+           ;; file.
+           (add-after 'unpack 'preserve-license-file
+             (lambda _ (copy-file "LICENSE" "LICENSE.rtmp")))
+           (add-after 'preserve-license-file 'unpack-nginx-sources
+             (lambda* (#:key inputs native-inputs #:allow-other-keys)
+               (begin
+                 ;; The nginx source code is part of the module’s source.
+                 (format #t "decompressing nginx source code~%")
+                 (let ((tar (assoc-ref inputs "tar"))
+                       (nginx-srcs (assoc-ref inputs "nginx-sources")))
+                   (invoke (string-append tar "/bin/tar")
+                           "xvf" nginx-srcs "--strip-components=1"))
+                 #t)))
+           (replace 'install
+             (lambda* (#:key outputs #:allow-other-keys)
+               (let ((modules-dir (string-append (assoc-ref outputs "out")
+                                                 "/etc/nginx/modules")))
+                 (install-file "objs/ngx_rtmp_module.so" modules-dir)
+                 #t)))
+           (delete 'fix-root-dirs)
+           (delete 'install-man-page)))))
+    (home-page "https://github.com/arut/nginx-rtmp-module")
+    (synopsis "NGINX module for audio and video streaming with RTMP")
+    (description "This NGINX module provides streaming with the @acronym{RTMP,
+Real-Time Messaging Protocol}, @acronym{DASH, Dynamic Adaptive Streaming over HTTP},
+and @acronym{HLS, HTTP Live Streaming} protocols.  It allows NGINX to accept
+incoming RTMP streams for recording or redistribution.  It also supports
+on-demand streaming from a file on disk and pulling from an upstream RTMP
+stream.  Remote control of the module is possible over HTTP.")
+    (license license:bsd-2)))
+
 (define-public lighttpd
   (package
     (name "lighttpd")