Message ID | Yq5ItF28DdgYjupEkK0mqUDKipJbY9Ifb0ASCvq88@cp7-web-039.plabs.ch |
---|---|
State | Accepted |
Headers | show |
Series | [bug#49646,core-updates] gnu: meson: Update to 0.59.0. | expand |
Context | Check | Description |
---|---|---|
cbaines/applying patch | fail | View Laminar job |
cbaines/issue | success | View issue |
At least based on my local testing using "./pre-inst-env guix build --rounds=2 mesa", the meson upgrade fixes the reproducibility of mesa by stabilizing the link order of the LLVM libraries. I believe it will resolve the following issues: * https://issues.guix.gnu.org/35084 "Mesa is not reproducible (tested on staging)" * https://issues.guix.gnu.org/43849 "mesa is not reproducible" * https://issues.guix.gnu.org/48552 "mesa 20.2.4 is not reproducible" Cheers, Kaelyn
Hi, Kaelyn Takata <kaelyn.alexi@protonmail.com> skribis: > * gnu/packages/build-tools.scm (meson): Update to 0.59.0, which includes a > reproduceability fix for builds that link against multiple LLVM libraries. Pushed as b15c3dd9b0e9cf6858f730e1d46c35ed9ab6a758. > At least based on my local testing using "./pre-inst-env guix build --rounds=2 mesa", the meson upgrade fixes the reproducibility of mesa by stabilizing the link order of the LLVM libraries. I believe it will resolve the following issues: > * https://issues.guix.gnu.org/35084 "Mesa is not reproducible (tested on staging)" > * https://issues.guix.gnu.org/43849 "mesa is not reproducible" > * https://issues.guix.gnu.org/48552 "mesa 20.2.4 is not reproducible" Oh nice. I added a “Fixes” line to the commit log. We’ll run ‘guix challenge’ once we have several builds of it (later on because right now ci.guix only builds core packages on this branch and bordeaux.guix doesn’t built it yet). Thanks! Ludo’.
diff --git a/gnu/packages/build-tools.scm b/gnu/packages/build-tools.scm index 6285ecabf3..9798cd12b2 100644 --- a/gnu/packages/build-tools.scm +++ b/gnu/packages/build-tools.scm @@ -264,7 +264,7 @@ files and generates build instructions for the Ninja build system.") (define-public meson (package (name "meson") - (version "0.58.1") + (version "0.59.0") (source (origin (method url-fetch) (uri (string-append "https://github.com/mesonbuild/meson/" @@ -272,7 +272,7 @@ files and generates build instructions for the Ninja build system.") version ".tar.gz")) (sha256 (base32 - "0padn0ykwz8azqiwkhi8p97bl742y8lsjbv0wpqpkkrgcvda6i1i")))) + "0xp45ihjkl90s4crzh9qmaajxq7invbv5k0yw3gl7dk4vycc4xp3")))) (build-system python-build-system) (arguments `(;; FIXME: Tests require many additional inputs and patching many