diff mbox series

[bug#49475] linux-boot: Resume from hibernation after pre-boot.

Message ID 20210709024853.1170-1-jackhill@jackhill.us
State Accepted
Headers show
Series [bug#49475] linux-boot: Resume from hibernation after pre-boot. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Jack Hill July 9, 2021, 2:48 a.m. UTC
* gnu/build/linux-boot.scm (boot-system): Call resume-if-hibernated
after pre-mount.
---

This change allows resuming from a swap device that needs device-mapper
to be set up first. In my case I tested swap on lvm on dm-crypt. I
believe this change to be safe since pre-mount shouldn't mount or
otherwise touch the filesystems. It it did, there would be data
corruption, so special care should be taken when reviewing.

 gnu/build/linux-boot.scm | 18 +++++++++---------
 1 file changed, 9 insertions(+), 9 deletions(-)

Comments

Tobias Geerinckx-Rice July 9, 2021, 3:21 a.m. UTC | #1
Jack Hill 写道:
> * gnu/build/linux-boot.scm (boot-system): Call 
> resume-if-hibernated
> after pre-mount.

All right! \o/  Whilst I'm glad it didn't eat your data, it was 
still just an off-the-cuff suggestion on IRC & I'd like to take 
the weekend to think about the whole picture.

Kind regards,

T G-R
diff mbox series

Patch

diff --git a/gnu/build/linux-boot.scm b/gnu/build/linux-boot.scm
index 461df9ff46..778ee99690 100644
--- a/gnu/build/linux-boot.scm
+++ b/gnu/build/linux-boot.scm
@@ -563,15 +563,6 @@  upon error."
         (load-linux-modules-from-directory linux-modules
                                            linux-module-directory)
 
-        (unless (or (member "hibernate=noresume" args)
-                    ;; Also handle the equivalent old-style argument.
-                    ;; See Documentation/admin-guide/kernel-parameters.txt.
-                    (member "noresume" args))
-          ;; Try to resume immediately after loading (storage) modules
-          ;; but before any on-disk file systems have been mounted.
-          (false-if-exception           ; failure is not fatal
-           (resume-if-hibernated (find-long-option "resume" args))))
-
         (when keymap-file
           (let ((status (system* "loadkeys" keymap-file)))
             (unless (zero? status)
@@ -606,6 +597,15 @@  upon error."
           (unless (pre-mount)
             (error "pre-mount actions failed")))
 
+        (unless (or (member "hibernate=noresume" args)
+                    ;; Also handle the equivalent old-style argument.
+                    ;; See Documentation/admin-guide/kernel-parameters.txt.
+                    (member "noresume" args))
+          ;; Try to resume immediately after loading (storage) modules
+          ;; but before any on-disk file systems have been mounted.
+          (false-if-exception           ; failure is not fatal
+           (resume-if-hibernated (find-long-option "resume" args))))
+
         (setenv "EXT2FS_NO_MTAB_OK" "1")
 
         (if root-device