diff mbox series

[bug#48599] gnu: Add omemo-wget.

Message ID 20210523073802.20621-1-rg@raghavgururajan.name
State Accepted
Headers show
Series [bug#48599] gnu: Add omemo-wget. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Raghav Gururajan May 23, 2021, 7:38 a.m. UTC
* gnu/packages/messaging.scm (omemo-wget): New variable.
---
 gnu/packages/messaging.scm | 41 ++++++++++++++++++++++++++++++++++++++
 1 file changed, 41 insertions(+)

Comments

Simon Tournier July 2, 2021, 10:23 a.m. UTC | #1
Hi Raghav,

I have not tried this patch.  It is 4 weeks so maybe you can push it if
it builds and works for you. WDYT?


On Sun, 23 May 2021 at 03:38, Raghav Gururajan <rg@raghavgururajan.name> wrote:
> * gnu/packages/messaging.scm (omemo-wget): New variable.
> ---
>  gnu/packages/messaging.scm | 41 ++++++++++++++++++++++++++++++++++++++
>  1 file changed, 41 insertions(+)

[...]

> +(define-public omemo-wget
> +  (package
> +    (name "omemo-wget")
> +    (version "0.3.0")
> +    (source
> +     (origin
> +       (method git-fetch)
> +       (uri
> +        (git-reference
> +         (url "https://github.com/roobre/omemo-wget")
> +         (commit (string-append "v" version))))
> +       (file-name (git-file-name name version))
> +       (sha256
> +        (base32 "0s3vfaicw5xbjl9yiyr4ckrzhzqbvfh1w2ih1igavlfpgw4v7kva"))))
> +    (build-system go-build-system)
> +    (arguments
> +     `(#:import-path "github.com/roobre/omemo-wget"
> +       #:phases
> +       (modify-phases %standard-phases
> +         (add-after 'unpack 'patch-source
> +           (lambda* (#:key inputs #:allow-other-keys)
> +             (let* ((xdg-utils (assoc-ref inputs "xdg-utils"))
> +                    (xdg-open (string-append xdg-utils "/bin/xdg-open")))
> +               (substitute* (find-files "." "\\.go$")
> +                 ;; To correct the import path of 'aesgcm' package.
> +                 (("roob\\.re/omemo-wget/aesgcm")
> +                  "github.com/roobre/omemo-wget/aesgcm")
> +                 ;; To use absolute path of 'xdg-open' program.
> +                 (("xdg-open") xdg-open))))))))
> +    (inputs
> +     `(("go-github-com-pkg-errors" ,go-github-com-pkg-errors)
> +       ("xdg-utils" ,xdg-utils)))       ; for xdg-open program
> +    (home-page "https://github.com/roobre/omemo-wget")
> +    (synopsis "CLI to download and decrypt aesgcm:// URLs")

Maybe as synopsis: "Command-line interface for downloading and
decrypting @code{aesgcm://} URLs".  WDYT?

Cheers,
simon
Raghav Gururajan July 16, 2021, 9:52 a.m. UTC | #2
Hi Zimon!

> I have not tried this patch.  It is 4 weeks so maybe you can push it if
> it builds and works for you. WDYT?

I'll look into this patch today. :)

Regards,
RG.
Raghav Gururajan July 19, 2021, 1:02 a.m. UTC | #3
Hi Zimoun!

> I have not tried this patch.  It is 4 weeks so maybe you can push it if
> it builds and works for you. WDYT?

Yes, pushed as 2fbffcf575 to master.

> Maybe as synopsis: "Command-line interface for downloading and
> decrypting @code{aesgcm://} URLs".  WDYT?

I used your suggestion.

Thanks!

Regards,
RG.
diff mbox series

Patch

diff --git a/gnu/packages/messaging.scm b/gnu/packages/messaging.scm
index 59c154b9f7..f26df7dd46 100644
--- a/gnu/packages/messaging.scm
+++ b/gnu/packages/messaging.scm
@@ -72,6 +72,7 @@ 
   #:use-module (gnu packages glib)
   #:use-module (gnu packages gnome)
   #:use-module (gnu packages gnupg)
+  #:use-module (gnu packages golang)
   #:use-module (gnu packages gperf)
   #:use-module (gnu packages graphviz)
   #:use-module (gnu packages gstreamer)
@@ -125,6 +126,7 @@ 
   #:use-module (guix build-system cmake)
   #:use-module (guix build-system glib-or-gtk)
   #:use-module (guix build-system gnu)
+  #:use-module (guix build-system go)
   #:use-module (guix build-system meson)
   #:use-module (guix build-system perl)
   #:use-module (guix build-system python)
@@ -137,6 +139,45 @@ 
   #:use-module (guix packages)
   #:use-module (guix utils))
 
+(define-public omemo-wget
+  (package
+    (name "omemo-wget")
+    (version "0.3.0")
+    (source
+     (origin
+       (method git-fetch)
+       (uri
+        (git-reference
+         (url "https://github.com/roobre/omemo-wget")
+         (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "0s3vfaicw5xbjl9yiyr4ckrzhzqbvfh1w2ih1igavlfpgw4v7kva"))))
+    (build-system go-build-system)
+    (arguments
+     `(#:import-path "github.com/roobre/omemo-wget"
+       #:phases
+       (modify-phases %standard-phases
+         (add-after 'unpack 'patch-source
+           (lambda* (#:key inputs #:allow-other-keys)
+             (let* ((xdg-utils (assoc-ref inputs "xdg-utils"))
+                    (xdg-open (string-append xdg-utils "/bin/xdg-open")))
+               (substitute* (find-files "." "\\.go$")
+                 ;; To correct the import path of 'aesgcm' package.
+                 (("roob\\.re/omemo-wget/aesgcm")
+                  "github.com/roobre/omemo-wget/aesgcm")
+                 ;; To use absolute path of 'xdg-open' program.
+                 (("xdg-open") xdg-open))))))))
+    (inputs
+     `(("go-github-com-pkg-errors" ,go-github-com-pkg-errors)
+       ("xdg-utils" ,xdg-utils)))       ; for xdg-open program
+    (home-page "https://github.com/roobre/omemo-wget")
+    (synopsis "CLI to download and decrypt aesgcm:// URLs")
+    (description "OMEMO-wget is a tool to handle cryptographic URLs,
+generated by OMEMO Multi-End Message and Object Encryption,
+during XMPP-based sessions.")
+    (license license:lgpl3+)))
+
 (define-public psi
   (package
     (name "psi")