diff mbox series

[bug#48953,v2,3/3] gnu: dino: Enable missing features.

Message ID 20210611011550.27628-3-rg@raghavgururajan.name
State Accepted
Headers show
Series [bug#48953,v2,1/3] gnu: dino: Remove duplicate inputs. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Raghav Gururajan June 11, 2021, 1:15 a.m. UTC
* gnu/packages/messaging.scm (dino)[phases](wrap-env): New phase.
[inputs]: Add gspell, gstreamer, gst-plugins-base, gst-plugins-good,
icu4c, libsrtp and webrtc-audio-processing.
---
 gnu/packages/messaging.scm | 21 ++++++++++++++++++++-
 1 file changed, 20 insertions(+), 1 deletion(-)

Comments

Jack Hill June 11, 2021, 3:35 a.m. UTC | #1
On Thu, 10 Jun 2021, Raghav Gururajan via Guix-patches via wrote:

> * gnu/packages/messaging.scm (dino)[phases](wrap-env): New phase.
> [inputs]: Add gspell, gstreamer, gst-plugins-base, gst-plugins-good,
> icu4c, libsrtp and webrtc-audio-processing.
> ---
> gnu/packages/messaging.scm | 21 ++++++++++++++++++++-
> 1 file changed, 20 insertions(+), 1 deletion(-)
>
> diff --git a/gnu/packages/messaging.scm b/gnu/packages/messaging.scm
> index 5be733f3a2..41f26ba8e0 100644
> --- a/gnu/packages/messaging.scm
> +++ b/gnu/packages/messaging.scm
> @@ -114,6 +114,7 @@
>   #:use-module (gnu packages sphinx)
>   #:use-module (gnu packages sqlite)
>   #:use-module (gnu packages tcl)
> +  #:use-module (gnu packages telephony)
>   #:use-module (gnu packages texinfo)
>   #:use-module (gnu packages textutils)
>   #:use-module (gnu packages tls)
> @@ -1241,6 +1242,17 @@ Encryption to Gajim.")
>                            (guix build glib-or-gtk-build-system))
>        #:phases
>        (modify-phases %standard-phases
> +         (add-after 'install 'wrap-env
> +           (lambda* (#:key outputs #:allow-other-keys)
> +             (let ((out (assoc-ref outputs "out")))
> +               (for-each
> +                (lambda (name)
> +                  (let ((file (string-append out "/bin/" name))
> +                        (gst-plugin-path (getenv "GST_PLUGIN_SYSTEM_PATH")))
> +                    (wrap-program file
> +                      `("GST_PLUGIN_SYSTEM_PATH" ":" prefix (,gst-plugin-path)))))
> +                '("dino")))
> +             #t))

Nitpick of a sort: Can we forgo the #t with the (hopefully soon) 
upcoming core-updates merge?

[…]

> +       ("gspell" ,gspell)               ; for spell-check support
> +       ("gstreamer" ,gstreamer)         ; for A/V support
> +       ("gst-plugins-base" ,gst-plugins-base)
> +       ("gst-plugins-good" ,gst-plugins-good)

[…]

> +       ("webrtc-audio-processing" ,webrtc-audio-processing))) ; for A/V support

Is there actual A/V support in this version of Dino, or is that only 
coming in 0.3.0?

Best,
Jack
Raghav Gururajan June 17, 2021, 12:19 a.m. UTC | #2
Hi Jackhill!

> Nitpick of a sort: Can we forgo the #t with the (hopefully soon) 
> upcoming core-updates merge?

I just kept that around for testing. Will be removing it in final patch.

> Is there actual A/V support in this version of Dino, or is that only 
> coming in 0.3.0?

Oh no no. It is meant to be commented, for enabling it in v0.3.0 
release. I sent the wrong patch. The correct one is in v4.

Regards,
RG.
diff mbox series

Patch

diff --git a/gnu/packages/messaging.scm b/gnu/packages/messaging.scm
index 5be733f3a2..41f26ba8e0 100644
--- a/gnu/packages/messaging.scm
+++ b/gnu/packages/messaging.scm
@@ -114,6 +114,7 @@ 
   #:use-module (gnu packages sphinx)
   #:use-module (gnu packages sqlite)
   #:use-module (gnu packages tcl)
+  #:use-module (gnu packages telephony)
   #:use-module (gnu packages texinfo)
   #:use-module (gnu packages textutils)
   #:use-module (gnu packages tls)
@@ -1241,6 +1242,17 @@  Encryption to Gajim.")
                            (guix build glib-or-gtk-build-system))
        #:phases
        (modify-phases %standard-phases
+         (add-after 'install 'wrap-env
+           (lambda* (#:key outputs #:allow-other-keys)
+             (let ((out (assoc-ref outputs "out")))
+               (for-each
+                (lambda (name)
+                  (let ((file (string-append out "/bin/" name))
+                        (gst-plugin-path (getenv "GST_PLUGIN_SYSTEM_PATH")))
+                    (wrap-program file
+                      `("GST_PLUGIN_SYSTEM_PATH" ":" prefix (,gst-plugin-path)))))
+                '("dino")))
+             #t))
          (add-after 'install 'glib-or-gtk-wrap
            (assoc-ref glib-or-gtk:%standard-phases 'glib-or-gtk-wrap)))))
     (native-inputs
@@ -1258,16 +1270,23 @@  Encryption to Gajim.")
        ("glib-networking" ,glib-networking)
        ("gpgme" ,gpgme)
        ("gsettings-desktop-schemas" ,gsettings-desktop-schemas)
+       ("gspell" ,gspell)               ; for spell-check support
+       ("gstreamer" ,gstreamer)         ; for A/V support
+       ("gst-plugins-base" ,gst-plugins-base)
+       ("gst-plugins-good" ,gst-plugins-good)
        ("gtk+" ,gtk+)
+       ("icu4c" ,icu4c)                 ; for emoji support
        ("libcanberra" ,libcanberra)
        ("libgcrypt" ,libgcrypt)
        ("libgee" ,libgee)
        ("libnice" ,libnice)
        ("libsignal-protocol-c" ,libsignal-protocol-c)
        ("libsoup" ,libsoup)
+       ("libsrtp" ,libsrtp)             ; for calls support
        ("pango" ,pango)
        ("qrencode" ,qrencode)
-       ("sqlite" ,sqlite)))
+       ("sqlite" ,sqlite)
+       ("webrtc-audio-processing" ,webrtc-audio-processing))) ; for A/V support
     (synopsis "Graphical Jabber/XMPP Client using GTK+/Vala")
     (description "Dino is a chat client for the desktop.  It focuses on providing
 a minimal yet reliable Jabber/XMPP experience and having encryption enabled by