diff mbox series

[bug#48938] gnu: python-hg-evolve: Update to 10.3.2.

Message ID 17df7d94bb725dcc409f8c20d9f9c6b9b333a241.1623256207.git.public@yoctocell.xyz
State Accepted
Headers show
Series [bug#48938] gnu: python-hg-evolve: Update to 10.3.2. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Xinglu Chen June 9, 2021, 4:30 p.m. UTC
* gnu/packages/version-control.scm (python-hg-evolve): Update to 10.3.2.
  [source]: Use ‘hg-file-name’ instead of ‘string-append’.
---
 gnu/packages/version-control.scm | 6 +++---
 1 file changed, 3 insertions(+), 3 deletions(-)


base-commit: 2d31eeecf06ab14732d374c75cdf6e7a55aa704e

Comments

Efraim Flashner June 13, 2021, 7:38 a.m. UTC | #1
Patch pushed. Thanks!
diff mbox series

Patch

diff --git a/gnu/packages/version-control.scm b/gnu/packages/version-control.scm
index 5900779de8..7562bd1675 100644
--- a/gnu/packages/version-control.scm
+++ b/gnu/packages/version-control.scm
@@ -1701,17 +1701,17 @@  interface.")
 (define-public python-hg-evolve
   (package
     (name "python-hg-evolve")
-    (version "10.3.1")
+    (version "10.3.2")
     (source
       (origin
         (method hg-fetch)
         (uri (hg-reference
                (url "https://www.mercurial-scm.org/repo/evolve")
                (changeset version)))
-        (file-name (string-append name "-" version "-checkout"))
+        (file-name (hg-file-name name version))
         (sha256
           (base32
-            "0msnp5fp8sz4q2r5xpcmm60h82kwkyg23y212v1xfp7ixkq9f4qa"))))
+            "0qgk39s5pwxbshfa6x1f1ccxahja3fs265dddxy6q99spy3b3x5h"))))
     (build-system python-build-system)
     (arguments
      ;; Tests need mercurial source code.