diff mbox series

[bug#48904,1/2] gnu: Add emacs-ytel.

Message ID 1f95f43ad23bf1cd567ced83d38fc31dcabd2e10.1623081191.git.public@yoctocell.xyz
State Accepted
Headers show
Series Add ‘emacs-ytel’ and ‘emacs-ytel-show’ | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Xinglu Chen June 7, 2021, 3:56 p.m. UTC
* gnu/packages/emacs-xyz.scm (emacs-ytel): New variable.
---
 gnu/packages/emacs-xyz.scm | 43 ++++++++++++++++++++++++++++++++++++++
 1 file changed, 43 insertions(+)

Comments

Nicolas Goaziou June 12, 2021, 8:31 p.m. UTC | #1
Hello,

Xinglu Chen <public@yoctocell.xyz> writes:

> * gnu/packages/emacs-xyz.scm (emacs-ytel): New variable.

Applied. Thank you.

> +      (version (git-version "0.0.0" revision commit))

I made it "0.1.0" according to the main file.  Same for the other package.

> +      (synopsis "Query YouTube via Invidious")

I rewrote the synopsis, since this one does not seem clearly related to
the project.

> +      (description
> +       "This package provide a major mode to search YouTube videos via an
> +Elfeed-like buffer.  Information about videos displayed in this buffer can be
> +extracted and manipulated by user-defined functions to do various things such
> +as:
> +
> +@itemize
> +@item playing them in some video player
> +@item download them
> +@end itemize")

The list wasn't strictly necessary so I appended it to the last
paragraph instead.

Regards,
diff mbox series

Patch

diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 1d954ec5bd..8ad6d1e119 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -21204,6 +21204,49 @@  youtube-dl backends are supported.  It is possible to create download profiles
 depending on the downloaded URL.")
     (license license:gpl3+)))
 
+(define-public emacs-ytel
+  ;; No releases.
+  ;; Commit from 2020-11-28
+  (let ((commit "d40bc7ead8d4d7e4d16b03b66a93d63bef51cc5f")
+        (revision "0"))
+    (package
+      (name "emacs-ytel")
+      (version (git-version "0.0.0" revision commit))
+      (source
+       (origin
+         (method git-fetch)
+         (uri (git-reference
+               (url "https://github.com/grastello/ytel")
+               (commit commit)))
+         (file-name (git-file-name name version))
+         (sha256
+          (base32
+           "0pxzfsxzrpv59dssrgx2mmwkm6rzk49ffjkgsa3wks7rdyfil3kf"))))
+      (build-system emacs-build-system)
+      (arguments
+       `(#:phases
+         (modify-phases %standard-phases
+           (add-after 'unpack 'patch-exec-paths
+             (lambda* (#:key inputs #:allow-other-keys)
+               (let ((curl (assoc-ref inputs "curl")))
+                 (substitute* "ytel.el"
+                   (("\"curl\"") (string-append "\"" curl "/bin/curl\"")))))))))
+      (inputs
+       `(("curl" ,curl)))
+      (home-page "https://github.com/grastello/ytel")
+      (synopsis "Query YouTube via Invidious")
+      (description
+       "This package provide a major mode to search YouTube videos via an
+Elfeed-like buffer.  Information about videos displayed in this buffer can be
+extracted and manipulated by user-defined functions to do various things such
+as:
+
+@itemize
+@item playing them in some video player
+@item download them
+@end itemize")
+      (license license:gpl3+))))
+
 (define-public emacs-org-web-tools
   (package
     (name "emacs-org-web-tools")