diff mbox series

[bug#48918,1/2] gnu: python-pyzmq: Enable tests.

Message ID 20210608132029.325312-1-monego@posteo.net
State Accepted
Headers show
Series [bug#48918,1/2] gnu: python-pyzmq: Enable tests. | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Vinicius Monego June 8, 2021, 1:20 p.m. UTC
* gnu/packages/python-xyz.scm (python-pyzmq)[arguments]: Remove #:tests?. Add
phase to build Cython extensions before tests.
[native-inputs]: Remove python-nose. Add python-cython, python-pytest.
---
 gnu/packages/python-xyz.scm | 12 ++++++++----
 1 file changed, 8 insertions(+), 4 deletions(-)

Comments

Leo Famulari June 8, 2021, 5:46 p.m. UTC | #1
On Tue, Jun 08, 2021 at 01:20:29PM +0000, Vinicius Monego wrote:
> * gnu/packages/python-xyz.scm (python-pyzmq)[arguments]: Remove #:tests?. Add
> phase to build Cython extensions before tests.
> [native-inputs]: Remove python-nose. Add python-cython, python-pytest.

Thanks!

I renamed the new phase to 'build-extensions', because we typically try
to avoid abbreviations. They can be confusing to those who are not
fluent in English.

Pushed as 172a0794bb9fe3af77ea459145bf7364b82c5cf2
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 9f961756b1..367c75f0f7 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -9162,14 +9162,18 @@  applications.")
     (arguments
      `(#:configure-flags
        (list (string-append "--zmq=" (assoc-ref %build-inputs "zeromq")))
-       ;; FIXME: You must build pyzmq with 'python setup.py build_ext
-       ;; --inplace' for 'python setup.py test' to work.
-       #:tests? #f))
+       #:phases
+       (modify-phases %standard-phases
+         (add-before 'check 'build-ext
+           (lambda _
+             ;; Cython extensions have to be built before running the tests.
+             (invoke "python" "setup.py" "build_ext" "--inplace"))))))
     (inputs
      `(("zeromq" ,zeromq)))
     (native-inputs
      `(("pkg-config" ,pkg-config)
-       ("python-nose" ,python-nose)))
+       ("python-cython" ,python-cython)
+       ("python-pytest" ,python-pytest)))
     (home-page "https://github.com/zeromq/pyzmq")
     (synopsis "Python bindings for 0MQ")
     (description