diff mbox series

[bug#48186] gnu: emacs-rime: Adjust to changes in emacs-build-system.

Message ID YI/+DhCQmYG/DMnv@thinkpad-x230-luhui
State Accepted
Headers show
Series [bug#48186] gnu: emacs-rime: Adjust to changes in emacs-build-system. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

luhui May 3, 2021, 1:43 p.m. UTC
Because of the update of emacs-build-system it cannot run correctly, fix it.
From 10b339344ac01724a19d8efa137425f4eba83cad Mon Sep 17 00:00:00 2001
From: luhui <luhuins@163.com>
Date: Mon, 3 May 2021 20:22:43 +0800
Subject: [PATCH] gnu: emacs-rime: Adjust to changes in emacs-build-system.

* gnu/packages/emacs-xyz.scm (emacs-rime):
[#:phases]: add patch-rime-module-path, change install-emacs-module
---
 gnu/packages/emacs-xyz.scm | 10 +++++++++-
 1 file changed, 9 insertions(+), 1 deletion(-)

Comments

Leo Prikler May 11, 2021, 5:32 p.m. UTC | #1
Am Mittwoch, den 12.05.2021, 00:16 +0800 schrieb Z572:
> I think #:include is better.
So do I.  Pushed as bb29c2657281dd2bc76c2fdb643bff4f3e4caed4.
Thanks.
diff mbox series

Patch

diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index dbeab25b39..9afe343a14 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -97,6 +97,7 @@ 
 ;;; Copyright © 2021 Stefan Reichör <stefan@xsteve.at>
 ;;; Copyright © 2021 Simon Tournier <zimon.toutoune@gmail.com>
 ;;; Copyright © 2021 Eugene Klimov <lipklim@mailbox.org>
+;;; Copyright © 2021 lu hui <luhuins@163.com>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -25706,6 +25707,13 @@  REPL appropriate to the current major mode.")
     (arguments
      '(#:phases
        (modify-phases %standard-phases
+         (add-after 'unpack 'patch-rime-module-path
+           (lambda* (#:key outputs #:allow-other-keys)
+             (make-file-writable "rime.el")
+             (emacs-substitute-variables "rime.el"
+               ("rime--module-path"
+                (string-append (assoc-ref outputs "out") "/lib/librime-emacs.so")))
+             #t))
          (add-after 'unpack 'patch-rime-data-path
            (lambda* (#:key inputs #:allow-other-keys)
              (make-file-writable "rime.el")
@@ -25721,7 +25729,7 @@  REPL appropriate to the current major mode.")
            (lambda* (#:key outputs #:allow-other-keys)
              (install-file "librime-emacs.so"
                            (string-append (assoc-ref outputs "out")
-                                          "/share/emacs/site-lisp"))
+                                          "/lib/"))
              #t)))))
     (inputs
      `(("librime" ,librime)