diff mbox series

[bug#48185] gnu: Add xmlsec-openssl.

Message ID 87fsz4uj1o.fsf@latte.josefsson.org
State Accepted
Headers show
Series [bug#48185] gnu: Add xmlsec-openssl. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Simon Josefsson May 3, 2021, 11:57 a.m. UTC
Hi!  I'm trying to make the OATH Toolkit recipe for Guix build the PSKC
parts.  Unfortunately I realized that the GnuTLS backend of xmlsec is
lacking some functionality that is required [1] [2], and that linking
against xmlsec-openssl solves this.  However, Guix doesn't have
xmlsec-openssl, so this patch is necessary before I can suggest a patch
for PSKC support in OATH Toolkit for Guix.

/Simon
[1] https://github.com/lsh123/xmlsec/issues/317
[2] https://gitlab.com/oath-toolkit/oath-toolkit/-/commit/89d144c711e7dcf9c449dacf3ba0d0ba24210a79

Comments

Ludovic Courtès May 5, 2021, 1:31 p.m. UTC | #1
Hi Simon,

Simon Josefsson <simon@josefsson.org> skribis:

> From a6e17a786497881f1eb8b9cff2fafba8034790db Mon Sep 17 00:00:00 2001
> From: Simon Josefsson <simon@josefsson.org>
> Date: Mon, 3 May 2021 13:49:33 +0200
> Subject: [PATCH] gnu: Add xmlsec-openssl.
>
> * gnu/packages/xml.scm (xmlsec-openssl): New variable.

Applied, thanks!

Ludo’.
diff mbox series

Patch

From a6e17a786497881f1eb8b9cff2fafba8034790db Mon Sep 17 00:00:00 2001
From: Simon Josefsson <simon@josefsson.org>
Date: Mon, 3 May 2021 13:49:33 +0200
Subject: [PATCH] gnu: Add xmlsec-openssl.

* gnu/packages/xml.scm (xmlsec-openssl): New variable.
---
 gnu/packages/xml.scm | 8 ++++++++
 1 file changed, 8 insertions(+)

diff --git a/gnu/packages/xml.scm b/gnu/packages/xml.scm
index 04cb09779b..931698a575 100644
--- a/gnu/packages/xml.scm
+++ b/gnu/packages/xml.scm
@@ -1253,6 +1253,14 @@  Libxml2).")
      '(#:configure-flags '("--disable-md5")))
     (synopsis "XML Security Library (using NSS instead of GnuTLS)")))
 
+(define-public xmlsec-openssl
+  (package/inherit xmlsec
+    (name "xmlsec-openssl")
+    (inputs
+     `(("openssl" ,openssl)
+       ("libltdl" ,libltdl)))
+    (synopsis "XML Security Library (using OpenSSL instead of GnuTLS)")))
+
 (define-public minixml
   (package
     (name "minixml")
-- 
2.20.1