diff mbox series

[bug#48220] gnu: xfce4-session: Add xset to propagated-inputs.

Message ID 20210504092051.24383-1-mail@brendan.scot
State Accepted
Headers show
Series [bug#48220] gnu: xfce4-session: Add xset to propagated-inputs. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Brendan Tildesley May 4, 2021, 9:20 a.m. UTC
* gnu/packages/xfce.scm (xfce4-session):[propagated-inputs]: Add xset so
that xflock4 can turn off the monitor.
---
 gnu/packages/xfce.scm | 2 ++
 1 file changed, 2 insertions(+)

Comments

Ludovic Courtès May 5, 2021, 1:23 p.m. UTC | #1
Hi Brendan,

Brendan Tildesley <mail@brendan.scot> skribis:

> * gnu/packages/xfce.scm (xfce4-session):[propagated-inputs]: Add xset so
> that xflock4 can turn off the monitor.

Can’t we instead patch ‘scripts/xflock4’ so that it refers to ‘xset’ by
its absolute file name?

However, my understanding is that the xset code is already a fallback:

--8<---------------cut here---------------start------------->8---
# else run another access locking utility, if installed
for lock_cmd in \
  "xlock -mode blank" \
  "slock"
  do
    set -- $lock_cmd
    if command -v -- $1 >/dev/null 2>&1; then
        $lock_cmd >/dev/null 2>&1 &
	# turn off display backlight:
	xset dpms force off
        exit
    fi
done
--8<---------------cut here---------------end--------------->8---

Probably we should ensure the first ‘for’ loop works as expected.
Perhaps we need to replace ‘xfce4-screensaver-command’ by its absolute
file name there.

WDYT?

Thanks,
Ludo’.
diff mbox series

Patch

diff --git a/gnu/packages/xfce.scm b/gnu/packages/xfce.scm
index 9655d8ccf7..f1e40a94b8 100644
--- a/gnu/packages/xfce.scm
+++ b/gnu/packages/xfce.scm
@@ -718,6 +718,8 @@  your system in categories, so you can quickly find and launch them.")
        ("libsm" ,libsm)
        ("libwnck" ,libwnck)
        ("libxfce4ui" ,libxfce4ui)))
+    (propagated-inputs
+     `(("xset" ,xset)))
     (home-page "https://www.xfce.org/")
     (synopsis "Xfce session manager")
     (description