diff mbox series

[bug#48217,9/9] gnu: sdrangel: Add dsdcc support.

Message ID 20210504085705.5298-9-glv@posteo.net
State Accepted
Headers show
Series Add sdrangel | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Guillaume Le Vaillant May 4, 2021, 8:57 a.m. UTC
* gnu/packages/radio.scm (sdrangel)[inputs]: Add dsdcc. Remove libxml2.
  [arguments]: Update 'configure-flags'.
---
 gnu/packages/radio.scm | 4 +++-
 1 file changed, 3 insertions(+), 1 deletion(-)

Comments

Leo Famulari May 4, 2021, 4:39 p.m. UTC | #1
On Tue, May 04, 2021 at 08:57:05AM +0000, Guillaume Le Vaillant wrote:
> * gnu/packages/radio.scm (sdrangel)[inputs]: Add dsdcc. Remove libxml2.
>   [arguments]: Update 'configure-flags'.

If you / we decide to package sdrangel with dsdcc support, let's do it
in a single commit that adds sdrangel with dsdcc support.
Leo Famulari May 4, 2021, 8:02 p.m. UTC | #2
On Tue, May 04, 2021 at 08:57:05AM +0000, Guillaume Le Vaillant wrote:
> * gnu/packages/radio.scm (sdrangel)[inputs]: Add dsdcc. Remove libxml2.
>   [arguments]: Update 'configure-flags'.

Also, why remove libxml2 in this commit?

Is it not required in patch 7/9?
Guillaume Le Vaillant May 4, 2021, 9:48 p.m. UTC | #3
Leo Famulari <leo@famulari.name> skribis:

> On Tue, May 04, 2021 at 08:57:05AM +0000, Guillaume Le Vaillant wrote:
>> * gnu/packages/radio.scm (sdrangel)[inputs]: Add dsdcc. Remove libxml2.
>>   [arguments]: Update 'configure-flags'.
>
> Also, why remove libxml2 in this commit?
>
> Is it not required in patch 7/9?

Although it is listed as dependency in upstream's wiki, I realized that
the 'configure' phase was not trying to find it, and the package builds
fine without it.

In the final version of the patch series, I'll put patch 8 after 6, and
merge patches 7 and 9 after patch 8.
I guess I'll also insert a patch adding mbelib for dsdcc, unless someone
as an objection.
diff mbox series

Patch

diff --git a/gnu/packages/radio.scm b/gnu/packages/radio.scm
index 85373e0b5b..a9c7447ec0 100644
--- a/gnu/packages/radio.scm
+++ b/gnu/packages/radio.scm
@@ -1761,13 +1761,13 @@  voice formats.")
        ("boost" ,boost)
        ("cm256cc" ,cm256cc)
        ("codec2" ,codec2)
+       ("dsdcc" ,dsdcc)
        ("faad2" ,faad2)
        ("ffmpeg" ,ffmpeg)
        ("fftwf" ,fftwf)
        ("hackrf" ,hackrf)
        ("libdab" ,libdab)
        ("libusb" ,libusb)
-       ("libxml2" ,libxml2)
        ("opencv" ,opencv)
        ("opus" ,opus)
        ("pulseaudio" ,pulseaudio)
@@ -1790,6 +1790,8 @@  voice formats.")
                             (assoc-ref %build-inputs "aptdec"))
              (string-append "-DDAB_DIR="
                             (assoc-ref %build-inputs "libdab"))
+             (string-append "-DDSDCC_DIR="
+                            (assoc-ref %build-inputs "dsdcc"))
              (string-append "-DSERIALDV_DIR="
                             (assoc-ref %build-inputs "serialdv"))
              (string-append "-DSGP4_DIR="