diff mbox series

[bug#47822] gnu: Add r-naturalsort.

Message ID 3d1ca65d2e40892c8effa6e4ed7e6a3948698b1a.camel@gnu.org
State Accepted
Headers show
Series [bug#47822] gnu: Add r-naturalsort. | expand

Checks

Context Check Description
cbaines/submitting builds success
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Roel Janssen April 16, 2021, 10:57 a.m. UTC
Hi Guix,

Here's a patch for r-naturalsort.

Also: is it OK to push patches like this ("another" fairly trivial R
package) directly?

Kind regards,
Roel Janssen

Comments

Efraim Flashner May 4, 2021, 3:52 p.m. UTC | #1
On Fri, Apr 16, 2021 at 12:57:51PM +0200, Roel Janssen wrote:
> Hi Guix,
> 
> Here's a patch for r-naturalsort.
> 
> Also: is it OK to push patches like this ("another" fairly trivial R
> package) directly?
> 
> Kind regards,
> Roel Janssen
> 

Probably. Plus it's been 2 weeks.
Leo Famulari May 4, 2021, 4:31 p.m. UTC | #2
On Fri, Apr 16, 2021 at 12:57:51PM +0200, Roel Janssen wrote:
> Here's a patch for r-naturalsort.
> 
> Also: is it OK to push patches like this ("another" fairly trivial R
> package) directly?

Yes. Quoting the manual section Commit Access:

------
For patches that just add a new package, and a simple one, it’s OK to
commit, if you’re confident (which means you successfully built it in a
chroot setup, and have done a reasonable copyright and license
auditing). Likewise for package upgrades, except upgrades that trigger a
lot of rebuilds (for example, upgrading GnuTLS or GLib). 
------

If you aren't feeling confident, just let us know what you'd like
someone else to check for you. Otherwise, feel free to push.
Roel Janssen May 4, 2021, 7:36 p.m. UTC | #3
On Tue, 2021-05-04 at 12:31 -0400, Leo Famulari wrote:
> On Fri, Apr 16, 2021 at 12:57:51PM +0200, Roel Janssen wrote:
> > Here's a patch for r-naturalsort.
> > 
> > Also: is it OK to push patches like this ("another" fairly trivial
> > R
> > package) directly?
> 
> Yes. Quoting the manual section Commit Access:
> 
> ------
> For patches that just add a new package, and a simple one, it’s OK to
> commit, if you’re confident (which means you successfully built it in
> a
> chroot setup, and have done a reasonable copyright and license
> auditing). Likewise for package upgrades, except upgrades that
> trigger a
> lot of rebuilds (for example, upgrading GnuTLS or GLib). 
> ------
> 
> If you aren't feeling confident, just let us know what you'd like
> someone else to check for you. Otherwise, feel free to push.
> 

Thanks Efraim and Leo.  I pushed this patch in
aa7eeabe9a782afc2535581298990050d16b1895.

I will push trivial patches like these directly from now on.  Please do
let me know if I pushed something that would've benefitted from review.

Kind regards,
Roel Janssen
diff mbox series

Patch

From 452a5561d9ab7623d52d0a6625f0199e8ff0e488 Mon Sep 17 00:00:00 2001
From: Roel Janssen <roel@gnu.org>
Date: Fri, 16 Apr 2021 12:53:06 +0200
Subject: [PATCH] gnu: Add r-naturalsort.

* gnu/packages/cran.scm (r-naturalsort): New variable.
---
 gnu/packages/cran.scm | 19 +++++++++++++++++++
 1 file changed, 19 insertions(+)

diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 6f931f06c2..012a734c30 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -25194,6 +25194,25 @@  addition, objects which include the k-d tree search structure can be returned
 to speed up repeated queries of the same set of target points.")
     (license license:bsd-3)))
 
+(define-public r-naturalsort
+  (package
+   (name "r-naturalsort")
+   (version "0.1.3")
+   (source (origin
+            (method url-fetch)
+            (uri (cran-uri "naturalsort" version))
+            (sha256
+             (base32
+              "0mz801y9mzld9ypp3xmsjw2d8l9q97sdnv09wrci9xi3yg2sjf6d"))))
+   (build-system r-build-system)
+   (home-page "https://cran.r-project.org/web/packages/naturalsort/")
+   (synopsis "Natural ordering")
+   (description "This package provides functions related to human natural
+ordering.  It handles adjacent digits in a character sequence as a number
+so that natural sort function arranges a character vector by their numbers,
+not digit characters.")
+   (license license:bsd-3)))
+
 (define-public r-muhaz
   (package
     (name "r-muhaz")
-- 
2.30.2