diff mbox series

[bug#48028,wip-gnome,v5,3/8] gnu: gtkmm: Add missing native-input and correct propagated-inputs.

Message ID 20210427092334.23537-3-rg@raghavgururajan.name
State Accepted
Headers show
Series [bug#48028,wip-gnome,v5,1/8] gnu: gtkmm: Change build-system and adjust arguments accordingly. | expand

Checks

Context Check Description
cbaines/submitting builds success
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Raghav Gururajan April 27, 2021, 9:23 a.m. UTC
* gnu/packages/gtk.scm (gtkmm)[native-inputs]: Add glib:bin.
[propagated-inputs]: Change; atkmm to atkmm-2.28, pangomm to pangomm-2.42,
and cairomm to cairomm-1.13.
---
 gnu/packages/gtk.scm | 10 +++++++---
 1 file changed, 7 insertions(+), 3 deletions(-)

Comments

M April 27, 2021, 5:43 p.m. UTC | #1
Raghav Gururajan via Guix-patches via schreef op di 27-04-2021 om 05:23 [-0400]:
> +     ;; Latest versions of atkmm, cairomm and pangomm,
> +     ;; are ABI incompatible with gtkmm.
> +     ;; Pkg-config checks for these ABI versions.

This addresses my remarks, thanks!

Greetings,
Maxme.
diff mbox series

Patch

diff --git a/gnu/packages/gtk.scm b/gnu/packages/gtk.scm
index 91bdfde092..f310e1c306 100644
--- a/gnu/packages/gtk.scm
+++ b/gnu/packages/gtk.scm
@@ -1632,6 +1632,7 @@  library.")
     (native-inputs
      `(("dot" ,graphviz)
        ("doxygen" ,doxygen)
+       ("glib:bin" ,glib "bin") ; For glib-compile-resources
        ("m4" ,m4)
        ("mm-common" ,mm-common)
        ("perl" ,perl)
@@ -1639,11 +1640,14 @@  library.")
        ("xsltproc" ,libxslt)
        ("xorg-server" ,xorg-server-for-tests)))
     (propagated-inputs
-     `(("atkmm" ,atkmm)
-       ("cairomm" ,cairomm)
+     ;; Latest versions of atkmm, cairomm and pangomm,
+     ;; are ABI incompatible with gtkmm.
+     ;; Pkg-config checks for these ABI versions.
+     `(("atkmm" ,atkmm-2.28)
+       ("cairomm" ,cairomm-1.13)
        ("glibmm" ,glibmm)
        ("gtk+" ,gtk+)
-       ("pangomm" ,pangomm)))
+       ("pangomm" ,pangomm-2.42)))
     (synopsis "C++ Interfaces for GTK+ and GNOME")
     (description "GTKmm is the official C++ interface for the popular GUI
 library GTK+.  Highlights include typesafe callbacks, and a comprehensive set of