diff mbox series

[bug#48059] gnu: python-libtmux: Fix build by removing tests broken by tmux update

Message ID 20210427132000.176985-1-edk@beaver-labs.com
State Accepted
Headers show
Series [bug#48059] gnu: python-libtmux: Fix build by removing tests broken by tmux update | expand

Checks

Context Check Description
cbaines/submitting builds success
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Edouard Klein April 27, 2021, 1:20 p.m. UTC
From: Edouard Klein <edouard@hex.lan>

tmux update from 3.1c to 3.2 breaks two tests in this package by quoting the
returned value of a tmux call. No harm done, a fix upstream is unlikely.
---
 gnu/packages/tmux.scm | 4 +++-
 1 file changed, 3 insertions(+), 1 deletion(-)

Comments

Tobias Geerinckx-Rice April 27, 2021, 1:39 p.m. UTC | #1
Edouard,

Edouard Klein 写道:
> tmux update from 3.1c to 3.2 breaks two tests in this package by 
> quoting the
> returned value of a tmux call. No harm done, a fix upstream is 
> unlikely.

Hm... why's that?  Does upstream not support their own test suite?

Thanks!

T G-R
Tobias Geerinckx-Rice April 27, 2021, 1:43 p.m. UTC | #2
Edouard,

Edouard Klein 写道:
> From: Edouard Klein <edouard@hex.lan>

Oh, you should change this to a routable mail address ;-)

  $ git config user.email edk@beaver-labs.com

Kind regards,

T G-R
Edouard Klein April 27, 2021, 4:24 p.m. UTC | #3
Tobias Geerinckx-Rice writes:

> Edouard,
>
> Edouard Klein 写道:
>> tmux update from 3.1c to 3.2 breaks two tests in this package by quoting the
>> returned value of a tmux call. No harm done, a fix upstream is unlikely.
>
> Hm... why's that?  Does upstream not support their own test suite?
>

The issue I opened last year about the two other tests failing is still
unresolved
https://github.com/tmux-python/libtmux/issues/281

There seems to be little ongoing development:
https://github.com/tmux-python/libtmux/commits/master

My suspicion is that the maintainer is using debian or another slow
distro that still use tmux 2, which I believe make the test pass (at
leat it did when I tested it last year)
https://packages.debian.org/buster/tmux

There is no way in Python to specify which version of tmux this is
supposed to run against. This is one of the strength of GNU Guix :)

So:
- the change in behaviour between tmux 2 and 3 is not
important enough to be noticeable in any of my use cases,
- I have little time,
- the maintainer upstream is likely using tmux 2, 


all-in-all, this makes me say that an upstream fix is unlikely because I
can't write it myself and nobody else is likely to, either.

> Thanks!
>
Thank you for maintaining Guix :)

> T G-R
Edouard Klein April 27, 2021, 4:26 p.m. UTC | #4
Tobias Geerinckx-Rice writes:

> Edouard,
>
> Edouard Klein 写道:
>> From: Edouard Klein <edouard@hex.lan>
>
> Oh, you should change this to a routable mail address ;-)
>
>  $ git config user.email edk@beaver-labs.com
>
$ git config --get user.email
edk@beaver-labs.com

I don't know why git send-email is using my hostname. I'll have to
investigate. Thanks for pointing it out :)

> Kind regards,
>
> T G-R
Edouard Klein May 28, 2021, 7:38 a.m. UTC | #5
Sorry to be a bother, but could we please merge this ? We depend on this
package and we have to use guix time machine because it is broken. We
would very much like to enjoy the new 1.3 features.

Thanks in advance,

Cheers,

Edouard.
GNU bug Tracking System writes:

> Thank you for filing a new bug report with debbugs.gnu.org.
>
> This is an automatically generated reply to let you know your message
> has been received.
>
> Your message is being forwarded to the package maintainers and other
> interested parties for their attention; they will reply in due course.
>
> Your message has been sent to the package maintainer(s):
>  guix-patches@gnu.org
>
> If you wish to submit further information on this problem, please
> send it to 48059@debbugs.gnu.org.
>
> Please do not send mail to help-debbugs@gnu.org unless you wish
> to report a problem with the Bug-tracking system.
M May 28, 2021, 7:56 a.m. UTC | #6
edk@beaver-labs.com schreef op vr 28-05-2021 om 09:38 [+0200]:
> Sorry to be a bother, but could we please merge this ? We depend on this
> package and we have to use guix time machine because it is broken. We
> would very much like to enjoy the new 1.3 features.

I guess it is good to merge, but someone else would have to actually commit
it! (I am not committer)

Sorry for the delay. Bugs and patches can easily get forgotten after a while.

Greetings,
Maxime
Edouard Klein May 28, 2021, 4:17 p.m. UTC | #7
Thanks, no worries, I understand :)
Maxime Devos writes:

> edk@beaver-labs.com schreef op vr 28-05-2021 om 09:38 [+0200]:
>> Sorry to be a bother, but could we please merge this ? We depend on this
>> package and we have to use guix time machine because it is broken. We
>> would very much like to enjoy the new 1.3 features.
>
> I guess it is good to merge, but someone else would have to actually commit
> it! (I am not committer)
>
> Sorry for the delay. Bugs and patches can easily get forgotten after a while.
>
> Greetings,
> Maxime
diff mbox series

Patch

diff --git a/gnu/packages/tmux.scm b/gnu/packages/tmux.scm
index f208fbfd93..9cd632f535 100644
--- a/gnu/packages/tmux.scm
+++ b/gnu/packages/tmux.scm
@@ -178,7 +178,9 @@  windows.")
              ;; https://github.com/tmux-python/libtmux/issues/281
              (invoke "pytest" "-vv" "-k"
                      (string-append "not test_show_option_unknown "
-                                    "and not test_show_window_option_unknown"))
+                                    "and not test_show_window_option_unknown "
+                                    "and not test_split_window_shell "
+                                    "and not test_new_session_shell"))
              #t)))))
     (home-page "https://github.com/tmux-python/libtmux")
     (synopsis "Python API for tmux")